targa alpha channel not there even with RGBA selected.


(Grizzly69) #1

I am having a problem with rendering in blender. I want to make tga files with alpha channels to composite in another program. I have RGBA selected, but when I open the tga in Gimp, there is no alpha channel. What am I doing wrong? Please help.


(RipSting) #2

In the Display buttons (F10) there is a button called “Premul”. This needs to be pressed instead of the currently selected “Sky”. If you hold your mouse cursor over these buttons you can get some tooltip help. You could use either Premul or Key, but Premul gives your objects anti-aliased edges if you have OSA turned on.


(Dittohead) #3

I don’t think targa has alpha channel capability.


(Grizzly69) #4

what other file formats do support alpha channels that blender outputs?

tga files were liked because they supported alpha channels. That was one of their advantages. Anyway, Axogon Composer recognized the alpha channel of my blender renders, but Gimp and Irfanview did not. Now Gimp used to see it a few months ago. But since then I have reformatted my drive and redid my setup. Even gimp in my linux setup didn’t recognize the alpha channel. Is there a setting in preferences or something?

I am at work right now and it won’t be until tomorrow that I can try out what Ripsting suggested.


(Dittohead) #5

well i guess i was wrong.


(kattkieru) #6

PNG files have wonderful alpha support, and compress better (generally) than targa images. Just a thought.

As for GIMP, it should recognize the alpha channel automatically on any 32 bit image. If it’s not, then you should either remove it and recompile or contact the authors.


(Koryo) #7

If you look at the source of the Targa loader for the gimp
(gimp-1.2.X/plugins/common/tga.c) you will see that there is still an alpha
channel item in the TODO list. I believe that this is a problem in the GIMP
and not with Blender. Other programs should open the Targa with alpha
support. (Note that many programs only have partial Targa support.)

As a temporary work-around either edit tga.c or use PNGs.

I hope that this helps.