Technical Problem

Ok, I have a problem when I start blender. After my computer has been running for one hour, It does opens blender to a black screen with the blender title and the ‘exit’, ‘minimize’ and ‘restore down’ buttons on the top bar. The rest is all black. I also get, upon startup the ‘Unable to locate Component’ error that reads: “This application has failed to start because QTCF.dll was not found. Re-installing the application may fix the problem.”

Within the first hour after startup, though it gives that message then blender works fine.

Well, have you tried copying that DLL file to the Blender directory? You should be able to find it in the QuickTime directory if you have it installed.
Even if Blender works the first time, getting an error message is still not normal.

Where in the directory do I put it? Where do I find it?

I already told you. This is a QuickTime library, so if you have QuickTime installed, you can search for the DLL in its directory, e.g. c:\Program Files\QuickTime or so. And you copy the file to the directory where you installed Blender, e.g. c:\Program Files\Blender or so. Or you could also copy it to a system-wide directory. It would probably work fine in c:\Windows\System32 or just c:\Windows.
Your machine is not going to explode, you know. Just try it!