Test Build/Shader docs.

Hey all,
Here is a start on documenting the game engine shaders. I will try to keep this documentation
as up to date as possible, add new sections, as well as document the changes made to the python interface.
Link

Included is also a new build. Some of you were having errors on code that was changed :expressionless:
It should be back to the way it was :smiley: If not let me know!
Build
Grass Demo (NoSound!)

And please, If you have submitted a bug to the game engine tracker can you confirm
that it is still there, or is fixed ?

Thanks,
snailrose…

thanks very much… I’m currently doing a little game using some of the shaders, will post as soon it’s usable…
In fact, there are onlyvery few bugs regarding the visual side of game engine, much more problems are with scene managment…

I just found a little bug in your grass demo :wink: there aro no textures in the file :smiley: but those squares synced to music are great…

FANTASTIC!

Included is also a new build. Some of you were having errors on code that was changed :expressionless:
It should be back to the way it was :smiley: If not let me know!

I created a simple water demo with 2.41 using the “vertexwave” demo .blend. It looks fine in 2.41 with my nVidia GeForce FX5500 (latest OpenGL 2.0 drivers) but in your build the reflective surface is not present. Here’s the blend for you to see for yourself. Check it out first in 2.41 and then your build.

http://www.pmudesign.com/downloads/OceanWave_packed.zip

Thank you very much for your great work in this area. I look forward to using your shader support and Erwin’s buoyancy in my ship’s sim. On that topic, have you had any success or have you tried to use any of the ocean shaders in your builds yet? I’m not much of a programmer, so when I tried to use the RenderMonkey shader, I’m afraid I didn’t get very far… :expressionless:

Thanks!

Oops I forgot to pack the file :smiley: It is updated now.

bigkahuna
Yep I know whats wrong, some changes broke backwards compatibly… It should be fixed soon :slight_smile:
You sure picked a difficult subject, Here is an interesting article on water maybe it can be of some help.

Thanks,
snailrose…

Thanks for the link, but it’s way over my head… :o

Snailrose thats AWSOME :smiley: , thanks!

the grass demo is beautiful and looks very intimate.
but for me dont loading the pa.mp3 file
on console writing that:

FMOD error! (33) An invalid object handle was used.

i found an other sound renderer audiere i dont know it is better but it have LGPL license and suppoorted many sound type (ogg, mp3, wav etc). and platroms.

and a question: in this version supported render to texture feature?

ciao

edem

Hey,

The fmod dll was put together really quick :frowning: have you tried a .wav file instead ?
just change the fmod.LoadFile argument to point to one of your songs
I will have to look at Audiere further it looks interesting

There is still no render to texture support :frowning: Its on my todo list, but I want to get some bugs
with the current state fixed first.

Thanks,
snailrose …

Nice documentation. This will really come in handy for my future video card. Maybe soon.

:o I can’t do anything, but shout woohoo!!!

Grass looks like when I was playing Fable, hehe. Might be a lot of grass, but here’s the specs running on my geforce 6600GT 128MB, P4 2.53 Mhz (22.2 fps).

Great work snailrose.

Jason Lin

I just tried the updated “grass demo” on my Athlon XP, GeForce FX5500 (256 mb, latest OpenGL 2 drivers) with 1 GB RAM and XP Pro. I get about 7.5 fps and no sound (?).

thank you also for taking the time to write the documentation

Hello Snailrose,

i converted and tested fmod.LoadFile("") pa.wav and pa.ogg too but it have same problem.

maybe i found an other bug with light Energy problem and i posted previously
here
and
here
the blend file.

Thanks,

edem

I looked into the “no sound” problem a bit further. When I run the “grass” demo, I get an fmod module not found error. I see that there’s an fmod.pyd file, but am not sure what a .pyd file is. My initial thought was that I didn’t have the files in the right directories… BIG BOO BOO! Warning to other folks: do not put the grass demo files in the same directory as the Blender executable. It crashed my system -big time-! Very repeatable, and XP had to go through it’s hard drive corruption check, etc.

So I never figured out how to get the sound to work, or how to past the “fmod” error, but I sure learned what NOT to do! :wink:

bigkahuna,
The files do need to be in the same directory as the blender build included in the
link. The .pyd is a .c python extension it allows compiled libraries to work with python.
I’m not sure what would cause the system crash, but untill I can look it,
I have removed the link to the grass demo.

edem,
Thanks for the blend and the link, it looks like the problem is in the same area
that bigkahuna is having problems with. This will be looked at very soon :slight_smile:

Thanks,
snailrose

Um… is it supposed to look like this?

Just checking. I was expecting something a little less… flatshaded. :confused:

Nice particles, though. :slight_smile:

[Edit: Updated my drivers. Still flatshaded polies for grass. :frowning: I’m on Windows qith an Nvidia card, so I know that’s two strikes against me, but is there anything at all you can think of that might help? I want Blender to be a viable next-gen gaming platform, I really, really want it. :frowning: ]

Attachments


As I think you already guessed, no it’s not supposed to look like that. I’m using an nVidia GeForce FX5500 and it shows the shaders fine (albeit a bit slow). Try updating your OpenGL drivers, there’s a new set of drivers on the nVidia website and that’s what I’m using.

i tried the grass demo and had to enable ztransp on the material of grass to make it working on my mobile radeon x600

Isn’t that more like a plus and another plus? Lol, all these guys keep saying OpenGL is better on the geforce cards and so far it seems to be on my 6600GT.

What model is your gfx card? Heh, maybe it doesn’t support the shaders… Download the full demos http://www.continuousphysics.com/ftp/pub/test/index.php?dir=blender/&file=GEdemos-2.41.zip and run the GLinfo.blend. See if the features are supported for your card. Cause it looks pretty awesome.

Jason Lin

does anybody know if the collision sensor in the cvs version works?(bullet) I couldn´t get it working (with property)