Texel Density Checker 3.2.1 [UPDATE 16.10.20]

Awesome to see a tool like this being made, super useful for environment work with tiling textures but it is a bit weird that its in px/cm, thats tiny and likely gonna be some weird decimal, maybe an option for px/m or whatever unit type you want.

Would it be possible to set pixels/m directly for a given res.
At the moment say I want to set something to 64px/m its a pain having to figure out the number to put into density when the computer could do that part, px/m is the only thing relevant as a user I want to think about and directly control.

Also being able to type an arbitrary resolution for whatever reason would be nice instead of being locked to the presets that only go as low as 512.

Nice start though thanks for making it, Im sure I’ll be using it a lot in the future if that gets sorted out, huge need for a tool like this.

Hi, nice script. I am having this issue. Any idea what might be the problem?

The script seems to work sometimes but it appears it might have a problem with sketch up files? I used a sketch up plugin to import the file into Blender. I am wondering if that might be the cause.

EDIT: Found solution. Export the Sketch up file scene as .fbx file after importing with the sketchup addon. Reimport the fbx file into a fresh new scene, try the Texel density addon and it will work fine.

You need delete render result from UV/Image Editor. Script try open UV/Image Editor and calculate UV Filling, but can’t because on this window opened “'Render Result”

Cant find the plugin after installation. No error or something. py File is in userfiles in “Blender\2.78\scripts\addons\Texel_Density_1_0_3”

What can i do?

Unzip downloaded archive and try install .py file instead .zip

Tried it already, its not popping up in the plugins list. Im on newest 2.78c

I got it, i copied the .py directly in the addon folder :slight_smile:

hi guys, can you help me with this?

i have a default cube and uv unwraped i made a uv grid 1024 * 1024 and set units to meters…
when i calculate td the result is 1.280 px/xm… is that ok?

i think the result should be 10.24px/cm!

ill thank you a lot if you can explain me why :smiley:

Added some improvements to the plugin for personal use a while ago and decided to share.

  • More texture sizes - from 64 to 4096
  • Support for non-square textures
  • Support for objects with changed scale
  • Fixed some terrible english in UI and messages (not in code comments, though)


Texel_Density_1_0_4.zip (3.59 KB)

Thanks for your sharing !

Thanks for good work

Awesome tool thanks, guys.

Hi. Does this work with the new 2.79 Blender release? Or is there another add-on like this one for the new version of Blender? I tried to install this with “Install from file” but nothing happens. The add-on doesn’t appear in the add-on list.

Hi. Does this add-on not work on 2.79? I tried installing it with “Install from file” but nothing happens. It doesn’t appear in the add-on list. Thanks

Unzip downloaded archive and try install .py file instead .zip

UPDATE 1.0.5!! (22.10.17)


  • Different Units for Texel Density: px/cm, px/m
  • Custom Texture Size and Aspect Ratio (Non-Sqare Textures)
  • Correct Texel Density for objects with non-uniform scale
  • UI Improvements
  • Minor bug fixes

Thanks Toomas Laik for implementation support non-square texture size

UPDATE 1.0.6!! (23.10.17)


  • Correct Texel Density for ANY Blender Unit System
  • Added more Units for Texel Density: px/in, px/ft

I’ve barely DL 1.05 and you uploaded another version :slight_smile:
Thanks for your work

UPDATE 1.0.7

  • Quick Preset Buttons for Set TD
  • Copy “Calculate” to “Set” Value
  • Fix: Using “,” separator for value