Text object - Can't change it's color?

I have no idea how to change it’s color…
Had a problem similar to this not too long ago, but it was solved by going to Objects > Display > Object Color.


I’ve set the material to white, made it shadeless, I even tried Python, but it didn’t allow me to have a texture attached to the colored object.

http://www.pasteall.org/blend/30513
Where did I go wrong?!

Thanks!

EDIT: Completely forgot to address my intentions - I want the text to be white, but for some odd reason it’s black. The ONLY way that works (so far) is switching the Blend Mode to ‘Mix’, which turns every other object in the scene shadeless… so that won’t work.

Have you tried using the Blender text object?

The text object is far superior, can have its color easily changed through the object color attribute, is more easily previewed, and can make use of multi-line strings (and yes, this means it works in the BGE).

I have, but never for keeping track of integers…
Is there really no other way? It’s been pretty reliable up until now :[

mix is the correct mode you say turning mix on makes all objects shadeless that makes no sense shadless is the option to turn a material shadeless, are you sharing one material over all your objects that changing one would affect all? your blend you uploaded is completely useless to debug your problems as all it contains is the ‘bitmap text’.

Is this what you want?

http://www.pasteall.org/blend/30547

Attachments


Hmm… not really :[
My ‘Map’ is already the desired color, but for some reason it doesn’t stay that way after pressing “P”.

I’m not sure if this is correct but it sounds that. For texture only use alpha influence, then in material tab switch the color you wish for the text. If you want to control it with Python, enable “Object Color” from Material tab in Options section.