Texture bake low quality

I have the file linked

it is a house and im trying to bake the roof. the shingles on the roof are high quality texture but it bakes at a low quality pixelated look. why is this?

FILE: http://www.pasteall.org/blend/36866

nice mesh, well done. by the way we need the texture aswell, otherwise it all turns purple.

Ill have to pack the textures and materials, ill post back in a few

ok Here is the file : )
http://www.pasteall.org/blend/36866

try a quick bake yourself and see the results

Was anyone able to download the file?

Your baked texture is only 1024 x 1024 px and you’re only using a relatively small area of that for the roof with all the wasted UV space. You’re in effect baking a high resolution image to a verylow resolution image, of course its going to be more pixelated. A 1024 x 1024 pixel image can only use a maximum of 1024 x 1024 pixels



ok take a look at richards reply. he knows a lot more than i do. i noticed his reply after posting mine…


(IMAGE FROM UV/IMAGE EDITOR AFTER BAKING)

ok to be honest, i’ve never used texture baking before, but here is here are my thoughts.
in the rendering settings close to “BAKE”, i changed the render type to Defuse Color, but i dont think that has anything to do with it. it did render a lot faster, but i dont know how that affected the outcome. just thought i would let you know.

so, i think the reason you get a such dodgy texture quality is because of the mapping node, witch has a scale set to -31.5.
I reduced the scale to -5, and unwrapped it again, and when i then took a look at the baking output, this (image above) is what i ended up with.
now, the image is just a small portion of the whole baked outcome, just to let you know. ill post the whole thing in a new reply.

the interesting thing is that when i baked it without reducing the scale of the mapping node, the whole texture had the low quality, but when i reduced the scale, only a portion was bad, and rest was good.
this makes me beleave that the good quality texture is the portion that i unwrapped again, and the bad portion was not unwrapped at all.

so my conclution is that it has SOMETHING to do with the mapping node, though i dont know why, or what it does.

what i would recomend you to do, is open the texture in a software, and array it, so you get a huge texture. then delete the mapping node, and unwrap face by face. DONT be afraid to place the UV islands on top of each other! once you think it looks good, click bake again, and it should work fine.


Ok thanks all! What i did was set the texture bake settings to 5120x5120, it created a huge png file but it was smooth. it took around 3 hours to bake the whole scene which isnt bad considering it is a huge file.