Texture Baker Result Problem

I Changed the title according to the new Problem with the texture baker skript below.
See my last post for the current problem (and I searched the forum)

Hi,

Maybe you could help me with my problem.
I’ve modeled some meshes, textured each of them seperately (not UV textures, but blender internal generated textures), but to export it to a single mesh for ogre I needed to join all these meshes into one.

after joining, the textures are still applied properly on the different parts, and the renders are also done with the right textures.

for importing the mesh an texturing it in ogre, i need to export the current “texture” (or whatever it is now) into a jpeg, … and texture it via UV.

how can this be done (converting the current texture into a UV texture, and then export it; the first part should be the tricky thing, where i didn’t find anything, how to do it), or maybe someone can help me with that.

The attachment includes the blend file (funnily the normals in the perspective/camera viewport seem to be inversed, but, rendering is still in the right way)

thx 4 help
grassi

(the blend file can be downloaded under this url: http://www.cgtalk.com/attachment.php?attachmentid=67982 )

You have to uvmap your object. The video at http://www.ibiblio.org/bvidtute/ might help you. Once you have the object uvmapped you run the Texture Baker from the UV menu in the uv editor header. This will copy your procedurals to a image file. Unfortunately you will have to adjust your uv’s slightly after baking.

GreyBeard

I thought UV map only works for mapping existing jpeg … textures onto a model.
unfortunately your link doesn’t seem to work (some sort of 404 error there)
is this the same tut as on the blender homepage?

Edit: found the homepage

OOPS – I screwed up the link.
Fixing it now. I believe it is the same one as on the Blender web site. UV mapping is not attached to any particular image. You can load several different images and they will all use the same mapping. The texture baker renders the procedural to your 2d mapping and saves it in a image file. The texture baker script was originally written so that procedurals could be used in the game engine which only accepts uv textures.

GreyBeard

Ok, I’ve watched the tut, and i know what I would have to do, if i want to draw the whole texture on my own.

But: in my case, the texture is perfect, but not uv mapped. in the beginning i had some objects, which i textured seperately (some only colored, others with some sort of color + noise map) which worked out very well. when i joined all of those objects into one mesh, somehow the texture of the diffenerent parts “stayed alive” and when I render my mesh now, the textures are still applied as in the past, where there were different objects.

i’m quite happy with my texture, and if i can avoid repainting it, it would be very good, because i’m not a pro in photoshop/fireworks/gimp …

so i was searching for a method, where i can say:
this is how i want tu unwrap my mesh (as it is done in the vt) AND
unwrap my current texture too and export it.
(maybe it is clearer now, what i want to do)

thx
grassi

The texture baker script paints the image for you using the colours of your already applied textures – you don’t have to manually paint anything. It a copy as it looks now to a my UV map machine :smiley:

The problem with the script is that it will be a little off – so you reload your baked texture image to the uv editor and adjust the mapping slightly to correct where it is off.

GreyBeard

[edit]
Hang on and I’ll do a little tuturoial with a cube

oh thx, that wasn’t explained in the vt

You are confusing two different commands – export uv map which exports the outlines to a jpg so you can paint it as shown in the tutorial and the texture baker.
I only pointed out the tutorial in case you didn’t know how to uv map.

  1. The cube with its uv mapping
    http://members.shaw.ca/rjplus/cube1.jpg
  2. Add a veroni procedural texture
    http://members.shaw.ca/rjplus/cube2.jpg
  3. A render of the cube with the procedureal
    http://members.shaw.ca/rjplus/cube3.jpg
  4. Run the texture baker
    http://members.shaw.ca/rjplus/cube4.jpg
  5. The render created by the texture baker – note it also baked the lighting in as well. If you dodn’t want this you should set the material to shadeless
    http://members.shaw.ca/rjplus/cube5.jpg
  6. The baked image loaded into the uv editor – note the adjustment required
    http://members.shaw.ca/rjplus/cube6.jpg
  7. After adjustment of uv map
    http://members.shaw.ca/rjplus/cube7.jpg
  8. The cube with the procedural texture turned off and the texface button turned on – There is still a little adjustment of the uvmap required but you should have the idea.
    http://members.shaw.ca/rjplus/cube8.jpg

Hi!

I followed your tutorial, and it worked apart from the texture baker part, where the error looked like the picture linked here:
http://stud4.tuwien.ac.at/~e0325080/Zeug/problem.png
The Unwrapped mesh with my own texture looks like this:
http://stud4.tuwien.ac.at/~e0325080/Zeug/unwrap.pdf

At first this was no problem, because I then exported the lines of the edges and drew a png, that looked like that.

Now, I’d need a better texture, and so I want to give the texture baker another try, but I don’t know what to do so that the output is right, and not like that. (recalcutlating normals didn’t help)

thx
g3k

Did nobody ever had such a problem?

your pic didn’t load

render frame 100, and make the render output square

also, if you move the camera created by jms’s texture baker to 100.5,100,5,0.5 and set the lens to 16 [before rendering] the adjustments to the uv after baking shouldn’t be necescary

The png? It works in my browser. (the pdf too)

what do you mean, by "make the render output square? same height, same width?

I am using the blender - built in texture baker. It doesn’t create a camera. (I wouldn’t mind the adjustments, if the output itself is correct, and doesn’t look like the polygons are randomized in some sort.
thx
g3k

okay, it didn’t load before

I am not going to register to download your .blend

the builtin texture baker creates a new mesh and camera, and renders from it

if you hit home in the 3d view you will see it…

position the camera at 100.5,100.5,0.5 and set the lens to 16.0, make the camera active [control+NUM0 with it selected] and make your render square. Re-render and the resulting image will be the properly baked [as in aligned to your uv coordinates] texture

the world color will still show through at the uv seams, which my texture baking script does something about… [kinda self plug, too lazy to rant more [do a search for texture baking if you care]]

however, looking at your pics this is not your problem, I’m not sure what it is, I’ve never seen it before.

Ah, you meant the blend file. Forgot about that (downloading the above one wouldnt be usefull at all, because thats from the time, where I hadn’t uvmapped it)

Here you can find the current one:
http://stud4.tuwien.ac.at/~e0325080/Zeug/blend.zip

If I hit “home” on my keyboard, there it seems as if it only zooms out, until I don’t see anything (the vieport has a lamp in the middle)(Is there any option in blender, where I can list all the things in my scene?)
So I couldn’t try out your hints.

What about your own texture baker script? Does this simply the same? Maybe I should try it out then.

If you wrote such a script, maybe you then could take a look at my .blend file?

thx
g3k

It seems to have problems with displacement maps - turn them off (replace them with bump maps or leave them off entirely) and try it again.

Yeah, the displacement maps were the Problem.

Thanks
g3k