Texture Baker Script and Halloween CVS build

Hi, I uv-unwrapped this gun turret,

http://deeplayer.com/dan_w/WCUweap/newtriple4.jpg

http://deeplayer.com/dan_w/WCUweap/tripleLOD1nooUV512Barrels.png

but whenever I try Texture Baker (to try and get the materials show on a texture) it tells me “active object is not a mesh or has no UV coordinates”. I’ve tried a million things; can’t figure it out; never happened to me before. I’m using the Halloween version from cvs. Here’s the file,
http://deeplayer.com/dan_w/WCUweap/tripleLOD1nooUV.blend

Please; I’m really stuck here; this never happened to me before… Calling the Texture Baker script, from the UV submenu of the Scripts menu gives me,

http://deeplayer.com/dan_w/WCUweap/error.png

About the only help I can give is suggest you work “Texture Baker Script” and “Halloween CVS build” into your title, to attract the attention of those brave bleeding-edge enthusiasts who might have some insight into your situation.

Yep, this happened to me too, the solution was that the script wasn’t updated for the new cvs version of Blender I was using. Don’t know if this is your case too. Somewhere, JMS posted an updated version of the script (on his site, probably) to work with last cvs builts.

Thanks. I changed the title as recomended.
Now, what I did was open the file in an older Blender version: 2.40 Alpha 1; and I still get the same message. I also tried creating a new .blend file (in 2.40) and appending the mesh. Same thing.

Somewhere, JMS posted an updated version of the script (on his site, probably)
Where can I find it? I’m not as much of a regular around here as I should be.

Try here:
http://www.blender.org/forum/viewtopic.php?t=7450&postdays=0&postorder=asc&start=150
bottom half of the page.

Thanks. Very odd, though; I downloaded, renamed the file, updated menus, and still gives me the same error.
In any case, found a solution: I exported to wavefront .obj + .mtl format, created a new .blend file with 2.40a, and imported the .obj. Not only does the texture baking work, but my project outline got cleaned up, and the file is half as big as it was.
http://deeplayer.com/dan_w/WCUweap/uvtext.png
But even if I open this file in the Halloween release, and using jms’ updated script, it still doesn’t bake…

Odd indeed. I suggest to post this in the bugtracker.

Heh, it gets even odder: Even with the new, lean and mean file, and using Blender 2.40a, as soon as I make any changes to the file, the texture baker stops working for me, and I have to repeat the export obj and re-import trick.

And odder still, even when it does work, and bake a texture for me, I still get the error message “the active object is not a mesh or has no UV coords”; it just pops up briefly after it finishes writing the texture :D:eek: