Texture Baking Weirdly

I’m trying to just get all my materials into one basic texture, so I baked them all into one, and for some reason it keeps turning out weirdly.

I read somewhere you need to have a light for it to bake properly in cycles? It was baking super dark, so I put in a light and baked it and this is what I got…


This is what it should look like.

It’s all just flat colours, so is there any way to just bake the colours without the lighting? I tried every combination of turning off the different settings for baking and on but it either comes out pure black or weird.

Thanks

The problem is the baking output margin. You need to leave some room around the UV islands when using margin, but in your case you can just set margin to 0 since you’re using the whole texture.
As for lighting you don’t need a light in the scene, you can bake as diffuse and turn direct and indirect off.

1 Like

Look at your bake settings. If you bake combined, you’ll get something that takes light into account. If you bake, for example, diffuse color, then you won’t.

If you want to bake flat colors, or any other weird value, plug your colors (numbers) into emission and bake emission.

Blutag is mostly right regarding margins. Margins might be a problem here. (I can’t see well enough.) But what you need are UV margins-- space between your UV islands. You don’t want to set the margin to 0 for the bake, it doesn’t matter that you’re using the whole texture, because margins are per-island, not per-image. You don’t want to use a larger margin for your bake than you’ve used for your UV mapping, however. (To change your UV margin, consider using ctrl p pack islands in the UV editor view and then look at / change the operator panel.)

1 Like

When using a proper UV unwrap, island margin is always good, but looking at his baked image, he probably unwrapped with Lightmap Pack. Setting a margin in such a case would just border every quad and waste a lot of texture space, that’s why I recommended margin 0 (a margin of just 1px also works for textures >= 256px since lightmap pack adds a small margin by default). Anyway, he should change unwrap method and use margin only if he still encounters artifacts.

By the way, be careful about the margin, UV unwrap tools have it in 0.0 - 1.0 range, while in render it’s in pixels. I find that a poor design choice.

1 Like

There is something weird about his bake. I thought it looked localized-- look at the spheres that are his eyes-- but all those squares look weird. Again, I can’t see it very clearly. And I don’t do lightmap packs except on early concept crap, because how hard is it to make real seams? But maybe you’re right.

But still, if he bakes with 0 margins, he’s just trading one problem for a different problem. If you’re using texture filtering (which you should use, and which MN is using), you don’t want 0 margins, or else you’re going to have something that looks fine at base miplevel only, with weird, only-shows-up-after-spending-a-week-rendering border artifacts. Worst kind of artifact to have. Not something where you wait until it’s broken to fix it.

Unless there are hidden 256 px per-island margins on a lightmap pack like you’re suggesting-- which would imply he’s using like a 16k texture, so I don’t think that’s the case.

Even if he doesn’t want to give it a real unwrap, doesn’t matter that you waste texture space, it’s better not to have border artifacts (or moire artifacts, the alternative)-- pack it with margins and rebake.

The solution is, give it a real unwrap, with UV island margins, and bake with margins.

Agreed fully. Blender can’t decide whether to treat us like we know what we’re doing or not. Unfortunately, there is some fundamental, theoretical knowledge required to make/understand 3D CG, and part of that is understanding the difference between texels and UV. They’re not equivalent.

But IIRC, at least it adds some units to the descriptions so that it’s clear enough. Much better than some other unitless differences…

2 Likes

I agree, Blender is a very strange tool. Some things are insanely hard to figure out and you need to google things that feel like they should be super easy to do(I.E. deleting animations, why is this so hard to figure out? lol)

Thanks, I smart UV mapped it, also I made the texture a bit bigger, I think 256x256 was a little too small, but I don’t know anything about texturing :stuck_out_tongue:

Ah, I didn’t mean to bake combined, but I looked in the settings and was wondering what was the setting for albedo. Thanks, I fixed it.