Texture becomes black?

i would like to reuse a texture in a second .blend file, i painted my character in the first file, and i would like to use this texture in a second file of the same character, but the result is terrible : on the left it is the good texture of the first file, in the middle is with the UV map and the option “generated”, and on the right, with the option “UV” but it is completely black :

I don’t understand what is happening, i can give you the .blend file if this can be of any help : http://www.pasteall.org/blend/19067

I have just made a copy of my first file, changed the position of its bones, and tried to reuse the texture.

Would you know how to fix this?

Thanks a lot

It’s not totally black, just that your uvs are totally screwed (see screenshot). Go back to an earlier version or import an earlier version of your model with correct UVs and use the Ctrl+L / join as UVs option to copy the uvs from the good model to this model


Thanks, i’m sorry i don’t understand how i should do it: i tried with only one file, i painted the character in white, then i exported the image “white.png”. I removed the image in the background in the uv editor, i then painted it in green this time, i exported the image “green.png”, and i removed the image in the uv editor background.

I tried both images as a texture in a material (and i assigned the material each time), but the character is still “black” : i marked the seams around the arm and the neck, so that i have these “islands” in the uv editor :

Could you help me a little bit more? Sorry again,


Any help?

in one of your posts, you say ‘generated’ as coordinate. I think you need to choose ‘UV’ from the drop down.

If you open Object Properties for charater, there is no UVmap whatsoever. Gone.
Have you unwrapped mesh at all? Is it imported from other software without UV information?
No seams which would allow easier painting.
If i add/do unwrap i can paint file ok.
There are normal issues on left hand - try to add subsurf modifier - they come up.

EDIT: sorry, okay it works!!! i think more seams changed it all! Thanks for all the answers, thanks also eppo!!!