Texture blurring?

It’s common and probably inevitable, but I wonder how to stop that blur effect that a texture gets with distance. IDK what it’s called, but it gets annoying.


I have an AMD Radeon HD7660D integrated card, if that helps.

I think that’s something that can be solved with anisotropic filtering. There’s a setting for it in the BGE, but you need to use Python to set it. You can also force it on in your graphics card driver settings, though obviously this won’t change the game at all - just how it displays (so it will be similarly blurry on other peoples’ computers unless they also changed their graphics card settings).

Thanks!! Works like a charm.

You can also use DDS textures with your own mip-map textures. This way you do not get the auto-generated mip-map levels.