Texture Display Problem


(TroutMask) #1

i’ve looked everywhere but it’s possible i missed it.

i want my uv mapped textures to show up in the 3d viewport. they render perfectly, but they appear in the 3d view as blotchy and unrecognizable.

i’ve just put up with it for the last 18 months or so i’ve been using blender, but i’m getting really tired of it.

is there a setting i’m missing?

http://img.photobucket.com/albums/v706/TroutMask/plastic_tray.jpg


(BeBraw) #2

What’s your graphics card?

Are you in “textured” mode? (viewport extured)


(TroutMask) #3

it’s an ATI. we have 5 macs in total that we have installed blender on and they all exhibit the same problem. mind you, they all have ATI graphics cards.


(BeBraw) #4

You might want to try to tweak your OpenGL settings. It is known that some ATI cards have problems with Blender.

Perhaps there are newer drivers you could try out.

Here are some links that might help:
http://blender.org/cms/Graphics_Cards.201.0.html
http://www.elysiun.com/forum/viewtopic.php?t=46445&highlight=ati+problem
http://www.elysiun.com/forum/viewtopic.php?t=23964&highlight=ati+problem
http://www.elysiun.com/forum/viewtopic.php?t=52646&highlight=ati+problem
http://www.elysiun.com/forum/viewtopic.php?t=53266&highlight=ati+problem


(TroutMask) #5

so you think it’s a graphics card problem and not a blender user setttings problem? if so that would mean i’m out of luck. we use macintosh systems which don’t allow one to alter the video card settings.


(BeBraw) #6

What is the exact model of your ATI card?

Have you tried out the newest drivers?


(mattebb) #7

In that screenshot, it looks like you are in shaded mode, which calculates materials and lighting per vertex. If you want to see UV textures, you need to be in Textured mode (Alt Z).


(TroutMask) #8

you are right it is shaded mode. but if i go into textured mode, every object that has a UV texture appears pure white.

any ideas?

BeBraw, i’m on a macintosh. apple supplies the drivers for the video card in the OS updates. i can’t alter them myself.


(SoylentGreen) #9

You switched “TexFace” on?


(TroutMask) #10

You switched “TexFace” on?

has no effect.

any mac users here who have been able to get this to work?

if every UV mapped object turns pure white in textured shaded mode, what does that mean?


(Fligh) #11

White is the default color for VColPaint. You must have pressed that button at some stage and wiped out your UVMapping. Unclick it and map your UV’s again.

%<


(TroutMask) #12

no that’s not it.

the uvs are intact. everything renders fine. i’ve produced literally hundreds of uv mapped objects - i know what i’m doing in that respect. it’s not a case of accidentally hitting something.

i just don’t know why the uv textures don’t display properly in the 3d window.

i’m going to take this to the developer’s forum and hopefully get an answer from one of the programmers there.

thanks everyone anyway for taking the time to try to help.


(patdog) #13

Take a look at this link http://membres.lycos.fr/bobois/index_anglais.html under section ‘Subdivide (subsurf) and see’.

If your planes have few vertexes the texture is blurred. Pump up the vertexes, and the computer gets cranky, but you can see all your maps.

Have followed the tut and know it can work this way, but let us know if you find a more effective solution.


(Spin) #14

I find that you have to render it at least once, then it will show up, instead of white.