Texture frame problem

I am having a problem with my texture. My texture on frame 20 is different then at frame 30. It is a camo texture and it is just in a different position. Does anyone know why this happening?

For something to change at a certain frame, you likley have an IPO set somewhere. Open the IPO window and make sure there are no Object or Texture IPO’s set that would effect that object or its texture. Also if you are using an Empty to place the camo texture make sure the empty is not moving with an IPO.

There is no empty and there is no IPO under “textures” in the IPO window.

If you want to upload your blend I will take a look at it.

If you look specifically at frame 61 and then go to 71 you can notice it easily. I think it is from the texture reacting with the lighting but i am not sure.


planeblend.blend (669 KB)

You have the texture Map Input set to Object coordinates instead of Orco or UV. This means as the object moves (in this case the plane, since no other object was specified) the texture moves. Try changing to Orco and adjusting the X Y Z size for the Map Input.

Ah i see, thanks. There is a problem though. I have tried messing with the values but i still cant get the right texture. Do you think this will be able to pull it off or do you think i should still mess with it?


it looks fine to me. Your other option would be to add an Empty and parent it to the plane and then use the Empty as your Object coordinates. You can then fine tune the texture placement by moving and scaling the empty. Since the empty is parented to the plane its relation to the plane will not change as the plane moves.