texture goes black on render??

hi
I’ve got a problem with my texturing for rendering…

it seems that the texture i place on to an object goes black when rendered as if it wasn’t there but it is? something else is weird. in the preview window the monkey is black but the rest of the previews are white as you would expect. i dont know what this means but I’m sure it should be white.

anyway I’m really confused I’ve done what i would normally do but its not working can anyone help…

attachment of a screen shot is bellow.

thanks

Attachments


In UVFace select mode goto F9, Texture Face tab and set the VertCol to white and press “Set VertCol”.

%<

thanks for the reply but it still isn’t working :frowning:
I’ve tried making a new material but still nothing. i then tried making a new object with other textures and it does the same thing.

i want to say its a bug but i could just be missing something.

stick with it 7immy, i think there is a setting messed up somewhere… i had that same problem… if i may add, your monkey head is black in the preview window as well… i am still very new to blender, but it looks like it is rendering what it should be if your monkey’s head is black too…

I get the same thing reproducibly - if using TexFace to view UV mapped textures in a render, switching to the monkey preview turns all vert colors to black. Switching to any of the other preview modes doesn’t cause the problem, but once you use the monkey it’s irreversible. Only restarting Blender (!) and not using the monkey preview seems to allow correct rendering.

I’ll report it to the bugtracker. In the meantime either avoid the Suzanne preview, or save the images, turn off texface, and map the images to UV in the material texture panels. This is a more flexible approach anyway since it allows you to use the images for bump, spec, etc. Unless you’re making game textures, which it appears you are.

its working!!!
Moving the images to the materials panel worked fine thank goodness(much better for what i want anyway). Its an animation im making for my tech coursework. i wanted to bake the AO to a mapped texture instead of generating it every frame to save on render times.

thanks again

Moving the images to the materials panel worked fine

Good to hear, I think this is a better practice for most texturing issues.

Submitted to the bugtracker.

I’m having the same problem, but I don’t understand what you mean by “moving the image to the Materials” could you elaborate?

Thanks kindly.

One “interesting” problem that can occur is when the surface-normals are facing “out” vs. “in,” and whether you’re doing things two-sided.

You could be looking at what is “obviously the outside surface” of something, but if the surface-normals are facing inward, guess what… it’s inside-out. And that (mumble, mumble) can cause “blackness.”