Texture Help - Coffee Liquid

Hello!

I’m new to Blender and am doing the most basic of Blender Guru’s tutorials: a coffee cup.

Everything is going fine except my coffee texture’s not rendering correctly during the final render.

These images show my renders and settings for the liquid. What am I doing wrong?

:sparkles: Never mind! I have solved the issue! :sparkles:

solved2

Turns out the liquid backup duplicate that I had hidden within my coffee cup was intersecting with the liquid texture I had wanted, thus creating the end result.

My new question however is, “how can I retain a backup duplicate and have it hidden without it showing up in the final render causing problems?” Because the only way I could solve this issue was deleting my liquid backup layer and I don’t want to do that.

Any help would be appreciated!

Move all your backup stuff into a new Collection and turn that collection off using the tick box in the Outliner (like you have done above for some Collections)

Thank you, John!

So I’m presuming that despite having my duplicate liquid layer hidden: it was showing up because it was parented to the rest of the cup? Or does parenting have nothing to do with it showing up, regardless of it being hidden, because it being under the master group of “Cup_Plate” being the reason why it was showing up regardless of it being hidden?

In this scenario of wanting to retain the wip liquid obj if I were to mess it up: I would just duplicate “Cup_Plate” in its entirety if I wanted to ensure the duplicate liquid remains parented to duplicated ( but finalized versions of ) the cup and plate?

Sorry if that’s a lot to respond to. :’)

Hitting H in the viewport only hides the object or objects from the viewport. They will still render.

There’s a wee button at the top of the Outliner called Filter. Make sure you open that and tick the options so that you can see all the options you might need. In my Outliner you can see I can toggle on and off the wee eye symbols, which controls viewport visibility and is the same as hitting H, as well as an icon that looks like a screen which disables the object in Viewport (same as H but Alt+H won’t unhide it) and a wee camera to disable in render.

So you could just turn it off for viewport and render using those icons or, as I said above, move backup stuff to its own collection and just turn the whole collection off)

image

Such an absolute disaster to have the default settings for the filter the way they are. Not a day goes by without someone new to Blender asking questions because of the decision to hide these. What were they sinking about? :slight_smile:

2 Likes

Wow! Never knew these existed! Then again I’m new so I know there’s a lot I need to learn.

I’ll be sure to make note of this in the future; very informative!

1 Like