Texture in render

hey guys and gals im trying to add a floor texture to my scene it shows up in textured mode in the 3d view but not in the render any ideas help would be most appreciated

You can play with textures inside Blender without a material, and still see them in the 3D window. To render an image however, you must tell Blender to use the UV Textures on faces when rendering. Do this by setting up a TexFace Material as shown. To do so, In the Buttons window, Shading buttons F5, Material settings, ADD NEW material. On the Material panel, enable TexFace.

I get the same issue, but only when I’m using yafray. I assume it would be somewhere in the Yafray and render tabs. Try fiddling with those.