Texture interpolation (pixilation)

How do I turn off texture interpolation? I’m trying to render a minecraft video useing blender 2.57, and if you know anything about minecraft, you would know that the texture is supposed to be pixelated. When I render my creeper the texture is all blurry. I‘ve tried everything to fix this! (turning off texture interpolation, turning off MIN map, and changing the render pixel filter,) but the result is only improved. The texture still isn’t sharp. What do I do?
Here are my rendered images

With interpolation:


Without interpolation and the best I can get it:


The reason I am posting this question is because I have used up all my resources in trying to find the answer, and it looks as if it might not even be possible… Is it possible? It should be…please help! :frowning:

turn off ‘mip map’ in texture buttons, and in the render buttons turn of OSA

OSA is the same as Anti-Aliasing right? and mip map was off… It still doesn’t work.
I probably should have posted my texture too
so as you can see … It has to stretch the pixels of the texture alot. I dont think blender can do this without the interpolation…I will just have to work around it. Am I right?

OSA is oversampling. Maybe I was thinking of the ‘key’ setting though ( which is also in render buttons ). Give that a try. And if it doesn’t work, how about making the texture larger? That should give the desired appearance, albeit a workaround.

I’ll just go with resizing the texture, since I cant find the ‘key’ setting. I don’t think the 2.5 blender has it or something.