Texture is being applied to another object?

I’m currently working on a tavern scene to experiment with pre rendered gaming environments. A lot of the objects were copied and pasted once I created them and several were one object that I then separated. As you can see in the picture that I will attach, the floor which is a separate object, is getting the texture that I applied to the walls. I tried alt+P to remove all parents and then apply the texture to the wall and it still happens. I will include my blender file as well for further inspection. Thanks advance.

That’s because the floor has the same material as the walls.

Judging by the material name and the name of the floor object I would guess that you just split the walls off of a default cube and later started tweaking their material. This material, however, was already present on the default cube itself, and as thus on the floor.

In short: change the material on the floor :slight_smile:

Ah thank you, that worked. I haven’t used blender in a while so I wasn’t really thinking. Thanks so much