Texture layer issue

Hi guys so i followed a couple tutorials on texture layers but it doesnt work here are 2 pics illustrating what i mean


This is the tutorial on the right hand side u can see hehas selected bump layer but the main texture is still applied to model


Now mine i just painted the model green but if i change layers it does not keep the main texture and when i try apply bump as u can see it just paints white or black line.

How can i maintain main texture while changing layers? blender 2.72

The steps i take.

  1. create new image base name it base
    2 uv unwrap and select new image base(base)
    3 go to texture menu add new texture name it base and assign base to it
    4 render image and see that the base image is applied
  2. pack or save image
    6 go to texture paint mode
    7 add new texture paint slot (any mode) call it bump
    8 here is where it makes no sense unlike the videos my main texture does not persist when creating or switching more layers.

To get any material effects (alpha blending, bump mapping, etc.), you should be in Texture (with shading set to GLSL) or Material viewport shading mode and have lights in your scene (on your screenshot you’re in Solid mode).

First, do you have a material in the material slot? If not, then the next thing won’t make sense.

Take a look down further on the texture panel. There should be a list of boxes under “Influence”. If color is selected, then any color of stroke you make will show. Unchecking that box will keep the color from showing. Also, look under “Geometry” and make sure the option for “Normal” is selected. In Blender Internal, this is where you get the bump effect.

On the Influence, anything that is checked will affect the image and anything unchecked will not. Color is usually selected by default. You can also use the texture to affect just about any other aspect, from transparency to reflectivity (aka mirror) to specular, and much more.

Woot its working. Think it was because i did not have a light in the scene. Thx for the help.

Ok here is step by step.
I press n under shading select glsl mode.
Go to materials select object create new material
Too be safe go into edit mode select all and assign material.
Then i open up editor and create new image call it base
i then do a smart uv unwrap and select base as the background
Then go to texture tab .
click new texture call it base and select the base image i scroll down and tick everything to be safe itensity mirror normal color the works
Go into texture paint just paint him all red
go to slots create new texture normal
color is not selected and normal is selected
When i switch layers the main base color remains now
And its working haha hmm

I wooted to soon:(. It only worked one time i been trying to do it again following my steps above and bubkiss am i missing a step?
Well finally seem to have got it working think it was a case of either forgetting to have texture mode turned on or glgs and probably sometimes both