Texture looks strange (blurry)

Hey. I have a 1024 by 1024 seamless texture which looks like gravel and have got it to repeat 25 times over the ground plane i have so the gravel doesn’t look to big

When the camera is zoomed out a bit it looks really strange and blurry which doesnt occur when it’s zoomed in

I am aware that when you zoom out you lose details but it just looks terrible and i am wondering if there is anything i can do to fix it

http://img151.imageshack.us/img151/5668/weirdonepf9.png
This is when the camera is zoomed out and you can see the floor is all strange and blurry

http://img372.imageshack.us/img372/7085/weirdtwojo4.png
when the camera is close to the ground it is clear and sharp with detail

Any suggestions would be great

thankyou in advance

i think you think it looks blurry because you want it to look like a road and have some contrast between light and dark where it is bumpy. Hence, I would suggest that you add a Nor value to the texture mapping, and a fairly strong light. Blender will do the rest.

The problem you have is caused by texture filtering. I don’t know what method Blender uses (but I bet it should be anisotropic). In fact it is not a fault of program, but cruel reality :frowning: Textures you have mapped onto the surface looks nice when looking perpendicular to the surface. But when the angle is smaller, then the texture is “squeezed” and this causes the blurriness, because the resolution in one direction lowered according to the angle. In this case you cannot help it.

But you may try to turn off mipmap generation and mainly texture interpolation to get sharper results (in texture panel). This should help it a bit, but don’t expect wonders. Those two functions don’t change textures very significantly, but they only produce a bit blurrier textures. Also try what PapaSmurf said about the bumps, increase the Nor strength a bit.

Look here http://wiki.blender.org/index.php/Manual/Image_Textures

Blender’s texture filtering isn’t that great… You can adjust it by lowering the ‘filter’ value in the image texture, at the expense of jaggies, or you could also try turning off mipmaps, at the expense of speed.

edit: beaten by myn.pheos!