Texture mapping backside of mesh

How do I assign a texture to each face of a cube, and stop the front textures showing through on the backside?

Here’s an example of what I mean:

http://x12.putfile.com/12/34111560794-thumb.jpg

http://x12.putfile.com/12/34111555069-thumb.jpg

I’m working on modeling a car using purely bump maps, and I’m stuck on applying the texture to the rear:

http://x12.putfile.com/12/34112051280-thumb.jpg

Hello

one of the joys of these forums ( and the “task”) of trying to help
people is that it’s always something new happen
You’re the “new” and…original :slight_smile:
What can I say…“modeling a car using purely bump maps”…well…
I’m not sure if I understand well your request
Anyway to apply a different texture to diferent faces or selections of faces of an object
you must use a multi-material ( material with many materials and textures inside)
In your case, you select each cube face at a time and assign a material /texture/image
to it
Do you know how to do it?
But of course, to apply textures to more complex objects you must use the UV Editor
Here’s a good tut:
http://download.blender.org/documentation/htmlI/ch11s05.html

Bye

Thanks for the reply Oto. Yes I understand assigning materials and textures. I figured it would need to use UV mapping for what I want to achieve, but just wanted to check.

I’m sure it’s not that “original” to use bump maps to create a car seeing as they’re used for many other things. I’ve just found that creating the seams and details on a car can become a tricky to achieve when using subsurf modeling.

All I’ve done is create the basic shape of the car mesh, and then applied a bump map to the front, side, and top drawn from the original blueprints. And then finally an alpha texture for the windows.

I figure it’ll save a shed load of time animating cars when high detail is not necessary i.e. cars in the background.

You’re probably right.
Provide that they “work” ( reach your goal), all techniques are good.
Bye

I think that the clip cube option where you load your texture image is what you are looking for if I understand you correctly. This is the option I use when I wish to add a decal and not have it appear on the far side of my model as well.

GreyBeard

Hmm, I’m having no luck with ClipCube GreyBeard. The image preview turns black and the renders are the same. Looks like I might have more luck mapping the textures to empty’s instead so I’ll give that a try.

I’m having no luck with ClipCube GreyBeard. The image preview turns black and the renders are the same. Looks like I might have more luck mapping the textures to empty’s instead so I’ll give that a try.

Sorry, I didn’t explain myself well. I do use an empty with the clip cube option. If you turn on the “bounds” in the draw menu you can see the clipping cube that the empty will use. Scaling the empty will change the clipping cube boundaries.

GreyBeard

Ok so I’ve got it all to work when using empty’s. Drawing the bounds boxes helps immensely, great tip! The trouble I’m having now is that even though all my textures are mapped only to ‘Nor’, they seem to be affecting the shading. You can see where the textures overlap:

http://x12.putfile.com/12/34120441597-thumb.jpg

I have 3 textures so far: Top, Side, and Front with their blending modes set to mix. I’ve tried all the other blending modes to no avail.

Here’s a close up:
http://x12.putfile.com/12/34120572041-thumb.jpg

You can see what ever is happening it’s not causing the mesh surface to be displaced. Very wierd. Any ideas?

I’ve had a similar problem when trying to indent some text – you could see the outline of the texture border. The solution was to make the badkground of the bumpmap a mid-grey (127, 127, 127). Values higher/lower than this will appear raised or lowerd. Try a couple of simple test maps on a cube to test. I’m fairly certain this will solve your problem.

GreyBeard

make the badkground of the bumpmap a mid-grey (127, 127, 127). Values higher/lower than this will appear raised or lowerd.

Yeah I’d set the background to grey for that very same reason. So I did a test on a cube as you suggested. It seems that not only is the shading affected, but also the specularity:

http://x12.putfile.com/12/34211484520-thumb.jpg

I then tried using image textures with an alpha background, but again the same problem occured.

Here’s the blend: http://squiggle.goldeye.info/misc/bumpmaptest.zip

Although I’m still baffled as to why the shading issue was occuring when using empties, I went ahead and used UV-mapping instead.

I’ll continue progress on the car here for those that are interested: http://squiggle.goldeye.info/experiments.htm#carbumpmap2

Thanks for everyones help and tips :slight_smile: