Texture Mapping in Viewport different to render

Hey Guys,
i’m currently working on an earth animation with BI and i switched from Multitextured to GLSL so i can see my camera position to the earth a little better.
Now i have a big problem, what i see in my viewport ist different to what i see rendered, by that i mean the texture mapping.
I see different portions of the surface, does anyone know whether i can fix it and how?


Your texture is probably not mapped right. If you have a UV unwrapped model and an image texture, multitexture view is just showing you the result of whatever image is currently loaded into the UV Editor, not the texture itself. Remember that the texture and the image are two different things. The texture uses the image according to its mapping settings. Check your texture settings and make sure its coordinates are set to UV and not Generated, which is the default. If that doesn’t work, post your .blend file with the textures packed (File>External Data>Pack into .blend file, then save) so we can actually see what’s going on instead of guessing.

Okay, thanks a lot.
I did’t know that it has to be unwrapped, I had a simple generated sphere projection before but now it works how i want it to.
Huge improvement for animation :smiley: