Texture messes up

It all started with this rock I made in blender… I put textures on it and it is in GLSL mode. Whenever I zoom out with my MMB, These black stripes slowly appear where my seams are. When I zoom in they disappear. How do I fix that?

Hello Sonic14, try fixing the seams in texture paint (smear or clone brush).

If that doesn’t help we’ll figure it out :wink:

PROBLEM: The Black lines don’t show up in texture paint mode. I tried it texture mode and solid mode and the black lines don’t show up.

I know the lines you are describing. Are you using a normal map? And additionally can you provide a blend file for inspection. :slight_smile:

here is the blend. Tell me if the texture is there. (There is only one texture.)

EDIT: There is no normal map.


rock.blend (1.64 MB)

This happen because of texture filtering in the 3d viewport. When viewed in texture paint mode, the textures are very crisp and sharp, and the pixels show up exactly as how they correspond to the uv coordinates. But when viewed in object mode with GLSL, showing the full image at all time is a waste of resources, especially when zooming out. Think about it, what is the point of rendering a 1024x1024 px texture when the object itself only takes up say 200 px screen size? So therefore the texture is filtered or maybe mipmapped down, and when that happens, the image is sort of re-scaled down. Now, if you rescale your texture down to e.g. 128x128 pixels, and then look at the UVs, you probably will notice that the edges of the UVs touch the black pixels. And thus, when you zoom out from the object, the “seams” appear, they are actually a part of the texture, what you see is the black color just outside the uv faces of the UV coordinates.

So essentially this is a texture problem. It’s easy to solve though, just make sure the seams in the UV-image editor are well within the texture, and far from the black color. When baking textures, increase the “Margin” setting to, say, 10 pixels and you won’t have any problems. If you are painting/cloning the texture from the texture paint mode, there is a margin setting there as well. In the tools menu to the left, under Project Paint, increase the “Bleed” setting. To fix an already generated texture, you could open it up in a image editing program, make the black “nothingness” fully alpha mapped and then but a similar texture in a layer below. Even a blurred version of the original texture placed under the original will do, as shown in the technique (although with a different purpose) here: http://cgtextures.com/content.php?action=tutorial&name=alphabg

Hope that helps.

Oh now I get it. OK I will try to do what you said.

It worked!!!

You don’t actually have to bake textures like that on rocks. Just use a tiling rock texture, and in the case of the rocks in my screen which have hollow bottoms, simply unwrap them with no seems, and play with the UV. No seems.