Texture misplacement

I’m not really sure if this is in the right place, but here goes. First off, im a newb. Sorry if this is a stupid problem. To make a long story short, in the viewport my model looks like this. /uploads/default/original/3X/1/d/1dea3b9839ed4d93f997a0226cd0dfa83ed23271.JPGstc=1&d=1259037271
This is what i want but when rendered it ends up like this with the texture sadly misplaced and wrongly sized. /uploads/default/original/3X/9/3/932fa41a99c7046642ae78e4a3cbb976b53a4237.JPGstc=1&d=1259037271
Can anyone help tell me why this is so?

Attachments



It looks like even though your mesh is UV mapped, your material isnt set up to use UV coordinates. In the materials panel, open the “map input” tab. This tab is used to tell the material how to map the texture around the mesh. To use the UV map click on the button that says UV(pretty straight forward). You can use the mouse-over tipss to find out more about the different options.

That did it, so thanks a lot. Kinda pathetic, ive been trying to figure this out all day. Again, thanks!

lol, nothing pathetic about it. I think everyone has spent a few sleepless nights hitting their head against their desk over something just as simple… I know i have.

You can always set ut a lot of texture layers and animate the opacity of the layers.

Either animate by hand or use a control null. Cyclist works for this.

Want me to produce an example?