Texture nodes behaving badly

I tried to create a brick wall using groups and multiple outputs using this tutorial, however Blender does not let me change the output using the drop down menu. Worse, it does not allow the different instances of the texture of have different outputs.


NodeProblems.blend (103 KB)

While there might be something picky, it would probably help if you say your OS and blender version, build no. If it’s anything different than 2.49, that is.
I did try this on blender 262.3 both win and linux. On linux, it refused to allow me to choose 4th output of nodes, did repeat one, like in some comment on tutorial page. On win box it did all nicely, however while blender versions are the same, actual build numbers likely are different. Again, i might have just learned “by hands” and am missing some significant “don’t do this” part.
In short - it works if you closely follow tutorial and it might show unexpected behaviour if done a bit differently. Start over in a new file.

Yeah, I forgot to mention that. I’m using OS 10.7.2 with an Intel processor. My version of Blender is 2.61.0 r42614. For what it’s worth, I tried starting over from a new file, but the it still will not let me set the outputs.

Just a thought - did you copy (Shift-D) output nodes, or Add New Output? I might have run into that ‘doesn’t allow’ while copy outputs in node editor… Can’t say for sure. Does .blend which can be downloaded on tutorial page work for you?
Other than that - :frowning: no idea…

I’m pretty sure I created a new output node for each output. Oddly enough, the downloadable .blend file works okay.

Thanks anyway.