Texture not rendered

sigh I feel like an idiot for not being able to figure this out. I’m pretty sure I’ve done everything right, but rendering is something I don’t do very often in Blender and I pretty much suck at it. Mostly I use Blender only to model stuff for game mods so the 3D preview is all I ever needed.

Ok, the problem:
I have a model, UVmapped and image texture assigned. The texture shows up alright in the 3D preview, but looks weird in the render preview (Shift-P).

On rendering (F12) the texture is absent altoghether and all I can see is the material colour on the model. In the attachment are the settings I used.

Everything else is set at default. I’ve looked at some other threads with similar looking problems though I couldn’t glean much information from them. Lighting is there, TexFace is enabled and then disabled, etc… I’m at a bit of a loss to figure out what I missed or did wrong. Can anyone point it out to me?


Sorry, but it looks to me like the preview does actually show texturing, albeit with a strong (lighting/mist?) blue-green color cast. What do you get when you do an actual render (F12)?

EDIT: Sorry, re-read your post about no textures in an F12 Render… hmmm… I’ll hafta think a bit…

Can you post a blend, even a modifed one that still shows the issue?

Blend and placeholder texture in this link: http://amade-wossname.com/tmp/blender/lat_bow.zip

Sometimes the render preview would show the render in proper colours if I move the window around but will always revert back to the greenish tint.

Thanks in advance.

In Shading (F5) -> World Buttons -> World, set the Ambient RGB value to black.

Ah, that solved the render preview but the actual render (F12) still don’t show any textures.

Also, the ambient colour didn’t show up as strong if at all in the render. Previous renders in a different scene with a strong ambient colour did not result in showing strong tints in the preview though, so I’m still a bit perplexed at why it’s acting like this in this particular scene.

Upon opening, I took the following actions:

  1. Selected Camera in object mode
  2. In 3D View, went to menu ‘Object’, then ‘Clear Apply’, then ‘Apply Visual Transform’
  3. In the buttons window, went to materials, then the World buttons, then turned Ambient to dark grey, almost black. Also, unselected ‘Blend’ in the preview pane.
  4. Re-oriented camera as needed to view the bow.
  5. Reassigned one window to be the UVImage editor. Clicked menu ‘Image’ then ‘Replace’. Browsed to your texture map and selected it.
  6. Clicked the button in the UVImage editor which looks like a small gift-box.
  7. Rendered (F12) (Render Preview also worked)

EDIT: (Items 1-4 I did because the camera orientation was all jacked up and was driving me flippin’ crazy. The actual fix was probably just reassigning your texture map and ensuring it was available to render.)


Yeah, that’s probably what it is.

I did everything as you outlined + some headbanging on the keyboard but the texture still won’t show up. I tried the exact same material settings on a different scene and model and it rendered alright. I’m not quite sure I understand what packing/unpacking (the gift box icon) the image texture does, but it didn’t seem to require it for that other scene.

So I gave up on the scene and appended the bow object into a new scene and after I reassigned the texture, added a new camera and a light source it rendered fine without having to alter any of its material settings or tinker with the UV. I’ve absolutely no idea why this is so. I tried going back to the old scene, deleted the material and reassigned a new one but it still won’t render the texture. I also tried removing the texture and reassigning a new one to it but still no dice either.

Fortunately I haven’t put much work into the old scene re materials and lighting. Hopefully it won’t happen again in the new scene, though I wish I knew what went wrong so I can avoid it in the future. Many thanks for your help so far.

I just figured out why the texture didn’t show up. I was using YafRay for the rendering engine whereas the new scene used Blender Internal. Is there any reason why YafRay won’t show textures or are there some special settings that need to be used with it?

In your original blend file, delete both of your lamps and add one new one.

Place it very close to your camera and try rendering again.

Still doesn’t work, unfortunately. Camera is new too. Maybe I’ll try searching the board for stuff regarding Blender YafRay rendering and hope some sort of explanation will comes up.
fingers crossed