Texture not showing in viewport

Hey all,

I UV unwrapped a plane and made a new image texture for it. The image texture is open in the object’s material nodes (see image below). However, in the texture paint mode, the object is always white. If I try painting, the UV image is affected, but I can’t see any change in the viewport. I’ve tried looking at it through both texture and solid viewport shading, but to no avail. Any ideas?


Update: I found out that I only have this issue whenever I’m adding new image texture and change the image size to 4096X4096. If I leave the default settings, there isn’t a problem. Does anyone know of a way to texture paint on a 4096X4096 image?

Given your screenshot, that’s indeed pretty strange. Have you restarted blender with factory settings and re-tried it ?

It’s weird. I just opened my saved project, and it’s all working correctly now. I don’t think I even did anything; it just seemed to fix itself on its own. Thanks anyway, ChameleonScales!

it looks a lot like your graphics card is not powerful enough to handle 4K textures in 3D. What’s your graphics card ?