Texture paint Image

I am using Blender 2.73A
I can’t send the file because it is too big… I have a question…

I have this character I created some time ago… a dog… I put markings on the dog’s body on the chest… white area…
it has always worked, always shows up like it should… no issues…
If I take the dog and put him into a Blender file all alone, attach the UV image, and render the image, it is showing as it should…

for some reason in this file it suddenly no longer shows.. I've checked all my settings, all are the same as in the single file of just the dog...  

I’m stumped as to what to check now to find out why the image is no longer working… I’ve only changed the location of the file when I did some file clean up, but I reset up the image (as I have done before) but cannot get it to show as it should… his head shows correctly but the body does not… I have created videos with the character so ned to try and get him to show up the same again…

any suggestions as to what I can check...  

thank you
Have a good day
Barbara

What does appear, pink?

Quick test. Open the image in photoshop or gimp and save it as a different name dog2.png, and then go into blender and set the image texture.

I opened the image in Photoshop and saved it as a different name… and set it as the image texture and still not showing…
my settings are
I added the image and didn’t change any setting under “Image”
Under “Image Sampling” did not make any changes… shows Alpha “Use” as checked, MIP Map checked, Interpolation is Checked, the filter is EWA, Eccentricity: 8 and filter size 1.00
Under "Image Mapping, shows Rrepeat, repeat x and Y are 1, crop min is .00 x & y crop max 1.0 x & y I didn’t change anything under it.
Under “Mapping” is coordinates: UV Map: UVMap Projection Flat didn’t change anything size xyz are 1.0
Under "Influence, Diffuse, color: 1. is checked… I didn’t make any changes here at all…

you asked what does appear pink…? Meaning?
I looked at the body in edit mode, with the UV/Image editor open, it shows the body unwrapped… go to Texture paint and it is showing the marking that is supposed to be on the body… shows fine…
at one point when I was trying to find out why it isn’t showing, I deleted the image and did the unwrap again in Edit mode, tried to set up new image but when I went to texture paint, the body showed up as Pink and didn’t find a way to get rid of the pink display… so just added the image back in…

thanks
am much confused at this point… especially since the dog shows as it should in a file with nothing in the scene but him a camera and light… but in the scene I am animating him in, it don’t show… My file is huge since I have much in it… so can’t send the file…

Hmm tough to say. If you have some blend with a material that works well you can always go file, append, browse to the blend, go to materials and append the material into your scene. Then select your dog, and in the slot where the material that isnly working is, click the little material icon (loosk like a world) and select the material you appended.

Is it possible you didn’t assign the material to the faces. select all verts in edit mode and with the correct material selected in the material tab, click ‘assign’

not sure… let me try that … I’ve tried everything else … It has always worked… I’ve done quite a few scenes with the dog and it has always worked… and looked fine… the other dog that is in the scene, no issue with her spots and the cat no issues with his stripes… and no issues with this dog’s head… only the body is a problem… strange…
I might have to come up with something in the story as to why he no longer has a white marking on his chest…
these are characters I use in children’s stories I write for a blog… been trying to play around with some animation videos with the characters…
thanks… going to try the suggestion and see if that works…

There’s on old saying in programming, fix the bug, don’t drop the feature. I’d try and figure out what is going on and you’ll be stronger for it.

here’s another thought, unwrapping again to try and fix uvs that once worked is rarely a good idea. Is it possible your new uvs just don’t line up with your old image?

Okay… went to edit mode with the body and made sure all verts were selected and then did “Assign” on the material, not working… it only shows the color of him… but no white marking on his chest… I’m stumped… … and since I’m learning this stuff, I’m really stumped when something looks as if it should be working and it don’t… and this one has really floored me since the settings haven’t changed… and he works in a smaller file but not in this one…

thanks

Post screenshots of all the material settings, and the texture settings.

I’m not sure you already did this, otherwise you should try and enter edit mode, select all, then in the UV editor chose the wanted image if it’s not yet there, so to assign it to the mesh.

paolo




x here are the images… sorry… got one in thee twice and can’t get it off… below it shows 2 files, here it shows 3…

thanks

sourvinos… tried that and it didn’t work either… thanks

I redid the image, did repaint of the image and that didn’t work either…

Here is the image in the UV/Image Editor

Attachments


First they are adorable.

Can you start a new file, append the dog into into it, pack the textures and save it and then post that. Maybe someone else sees something from the screenshot, I haven’t used BI in a while so I’d need to poke around the file.

I can do that… How do I pack the textures … I did it once but don’t remember what I did…
I already did a new file and appended the dog into it and in this new file, it shows as it should… no issues with it…

Okay… think I got the texture packed okay… here is the new file I created…

thanks

Jake Test File.blend (728 KB)

There’s no textures packed in this file. File, external data, ‘automatically pack into blend’ save file, close, post.

Okay… did the File/external/automatically pack … so hoping it’s there … sorry… I had seen an icon next to the texture image that said Pack so packed it… I wrote down in my notes how to pack so if I should have to do it again, I will know… thanks…

Attachments

Jake Test File 2.blend (903 KB)

open a uv editor window
select jake
tab into edit mode
zoom out until you can see dog in edit mode
hit a until all verts are selected and orange
hover over uv editor window
hit a until all uvs are selected and orange
select the image texture by clicking the ‘browse image icon’


select the jake-dog-body.png
tab into object mode

you should be able to texture paint, and renders will show the image texture

if you do paint more, remember you have to save the image after painting, by clicking ‘save image as’ in the uv editor.

Okay, thanks… going to try now…

No, not work… I did it twice and just will not pick up the image in this big file… :frowning: am going to try repainting again and save and see if that does it… I went into Edit mode, made sure all verts of the body was selected in the 3D view, then made sure all verts were selected in the UV Editor, then selected the texture image… in the UV editor and made sure it was the file under Textures… did a render and nothing… not there…

thanks