Texture Paint incredibly slow.

I am trying to hand-paint a skybox in texture paint mode, though even on my 8-core processor @ 4.0Ghz it still lags its way 1 frame update every like 2-3 seconds.
I am drawing on a cube, flipped normals, UV-unwrapped then subdivided once, 1024x1024 pixels texture.
It seems like if I have a low amount of movement on the brush I can draw almost real-time, no lag, though if I start to move around the brush a lot quickly it starts lagging a lot, only registering some spots my tablet drew on and drawing straight lines between these spots with the brush.
Also, an odd thing is that it seems like I get less lag when using a bigger brush :confused:
The lag is also far lower the first 3-4 strokes I make after Blender starts. Saving and packing the blend file also resets the amount of lag.
Disabling every project paint option doesn’t help in any way.
When looking at cpu usage Blender is using max. 14 % cpu distributed over all of the cores while drawing.

It is kind of hard to explain, but I hope someone can help.
Cheers!

There has been a lot of work on the texture paint mode in the last month, so give a try to a recent build on Blender :
http://builder.blender.org/download/

and see if you experience the same problem.

http://projects.blender.org/tracker/index.php?func=detail&aid=35057&group_id=9&atid=498

Please add your experiences and system specs to help the developers hunt this down.

When I wrote the thread, I was using r56498 also compiled by builder, the latest dev version (r56521) doesn’t solve the problem

I uploaded a video of the problem at http://www.youtube.com/watch?v=kLx_YiaHjI8

Video was taken from my livestream

I’ll see what I can do :slight_smile:
Do they need only my OS and gpu specs or the cpu as well? I have an overclocked 660ti 3Gb

Ouch, indeed that’s incredibly slow, considering your system it’s not normal, on mine with the same model as yours, it’s fast and smooth and i have a much weaker computer than yours

Can you make a screenshot of your File -> User Preferences -> System panel so i can try with the same settings as yours ?

http://pasteall.org/pic/50840

The more info the better. As you can see from that bug discussion and from this thread, the behavior is inconsistent between systems, so every little bit is crucial.

I gave a try with your settings and for me it’s nowhere slow as you (while testing i actually discovered that enabling Region Overlap while being on Triple Buffer window draw type iboost my texture paint mode performance, oddly).
But in the same time, my card can’t use Multisample, so maybe you using Multisample to 4 may have an influence on the Texture Paint performance, try set Multisample to No Multisample.

Noticing your nvidia, i remember now that Nvidia has a performance problem if for the model you have “Double Sided” enabled, so check if your subdivided cube does not have Double Sided enabled in the Object Data panel (the panel where you can find the vertex groups and more)
I remember

I’ll be attaching my system-info.txt then http://www.pasteall.org/42031/text

I managed to reproduce this slow strokes problem with a brush sized to 4 ! I paint circularly and i notice the brushes slowing really down, so instead of circles, it’s lines that are produced.

Very oddly anything above that size is fast and smooth.

I tried painting using factory blender settings, and it’s quite a bit faster, the problem is still there though (around 200 % improvement)

On default factory “Double Sided” is enabled on the default cube, so it’s important to disable it to avoid some performance loss in your test.

For my system with default factory it set Multisample to “No Multisample” but on an nvidia i don’t know i think there’s some level of Multisample by default , have you tried to set it to No Multisample to see if it has an impact (it should) on your texture paint performance ?

Disabling multisampling and making the cube single sided doesn’t affect performance in any way. :frowning:

Hopefully the devs will figure out the problem then, because considering your system specs the texture paint mode should just “fly”.
On your video i notice you’re in Cycle Render mode, i wonder if it has an impact.
Have you tried in Blender Internal mode ?

Cycles doesn’t have an impact on performance, I just tested it all on the internal (though I’m not sure if it would make a difference anyways, cycles and BI uses the same backend code for painting, right?)

There seemed to be difference in how it was handling texture related code, i remember this commit by example that hinted at some code being different :
http://www.miikahweb.com/en/blender/svn-logs/commit/54486

Blender 2.67 didn’t solve the problem, I need 2.67a!

have you tried changing the window draw method? mine was on full which caused the slowdown to single digit fps. now on automatic it never drops below 100fps while drawing