Texture paint is not working

I’m having troubles with texture painting. I’ve looked everywhere, and I cannot seem to find the solution. I follow all the basic steps and I cannot paint the texture neither in the panel nor in the 3d view. I checked and there’s no texture in brush.
I hope you can help me. I attach a video of the process. Thanks!!

It works for me if I reproduce your steps. From the videos it looks correct too.
Can look at it if you upload the file somewhere.

1 Like

I can send you the file I was working on.
I’m thinking this could be a compatibility problem with catalina OS.

It is not a problem with your OS. You have a black texture in your brush.

n-panel, brush settings, texture, remove it and it should work correctly.

1 Like

I thought it was the texture too. https://youtu.be/BaJ5oxFgfig
but when I remove it, I still get the same result. This is why I uploaded the first video with the default cube.

The only thing I do to be able to paint is removing the black texture. Are you using a tablet ? Could it be blender not reading the pressure sensitivity ?

1 Like

I’m Just using my trackpad or a mouse.

Not familiar with Mac OS, so it’s guesswork for now.

Are you using the app store to install blender ?
Saw that the file was saved on blender 2.81.16, it is not the last version.
Maybe try with the version here:

Try loading your file without loading the ui ?

1 Like

I did have the newer one, but didn’t work properly either. I reinstalled it, and restarted my computer. The brush started working.
Thank you so much!!

Have fun and happy blendering.

1 Like