Texture Paint missing small areas

I’ve been practicing texture painting more recently, and came across a problem that I’ve run into before in the past. When texture painting, I can notice small pixel sized gaps in between islands that have been UV unwrapped, even when the area isn’t on the edge of an island. Painting directly on the mesh doesn’t paint over these. Here’s an example where I have a mushroom model, but small gaps are still visible. Is there a way to fix this so I don’t have to paint on the image texture directly, and can figure out a way to still paint on the mesh directly?

Full view of mesh

Up close

UV map

Gaps on map

Maybe a density problem ? Or just rotate the viewport a little ??

(There was someting like that… maybe use the search function :mag: top right…)

The pixels that don’t get painted stay that way no matter what angle I paint at, but what do you mean by density? Maybe that’s it.

Couple things- how big is your image? Looks pretty small.

Turn your Bleed down:
2023-03-15 14_51_42-Blender

Turn your spacing down:

Try turning off Normal fall-off:

Also try setting your fall-off to Constant

I had the same problem with a 3D printable model I’m doing for a client right now. I wrote a blog about it on my Ko-fi Page

It might be the result of being in edge or vertex mode during the unwrap, but maybe not. I’ll have to play with it still.

But basically there are likely some floating faces/polys that may be stuck inside other UV islands. Your mesh is split up into islands when it’s unwrapped. Sometimes the Unwrap process will throw some of your individual polys out into their own islands. Sometimes those polys you want to paint brown will be thrown into the same island as a white so they get overlapped and stay white.

If you hover your cursor over each island and hit your ‘L’ key to select all your visible islands, then hit Ctrl>I to invert the selection, the floating polys will be more visible and you can just hit '‘G’ and move them out of the UV square, then find the ones you want brown and move them into the brown islands and vice versa for the white. Try that and see if it helps.

I had to break up my mesh into 5 parts because doing a UV Unwrap gave me dozens if islands and this issue was getting ridiculous.

I figured if I chose sections of my mesh that didn’t for, say, cylinders, where my mesh would get distorted, I could get more even flow. So to fix it I would first make sure selection in edit mode was on faces, not vertices or edges, otherwise you don’t select the entire face and get edges dangling off the edges of your mesh.

I would select a part of the dog that would be most flat and have the least protruding parts, so for example I would cut the cylinder of the front leg in half up-and-down so it would unwrap more flat, then unwrap what I selected, hide it, then when I selected the next bunch of polys that would have been connected to the first selection, I would hit Ctrl>+ a couple times so the selection would overlap into previous selection so ‘no polys left behind’ in the unwrapping process.

I explain it better, and with pictures, on my Ko-fi Page so check there if this doesn’t make sense. Good luck and let me know if it worked :slight_smile:


Welcome :tada:… and:

Thank you to enter this community with this valueable posting…

This isn’t always the case for some newcommers :wink:


@joseph This is very helpful! I didn’t know about these options so this will help me a lot! Unfortunately though that part of the mesh still doesn’t get painted over. I notice it’s where I have edge seams but clearing the seams doesn’t seam to help either. The image itself is 2024 x 2024 pixels.

@Dale_Ziemianski Hello and welcome! I hope you have good time here. :slightly_smiling_face:
Very good job on your own project as well!
It doesn’t look like there are any floating islands or bits in the UV map, as the part that isn’t getting painted is in the middle of the map, so I’m not quite sure what I’m doing wrong.


Here is the blend file, maybe this will help a bit. I know that I can paint directly on the image in this specific instance, I just want to know what is causing the problem so that I can address similar problems in the future.
paint_problem.blend (1.1 MB)

Ok…I don’t know HOW it happened but there is something wrong with the edges , where the dots appear…and they are dots as if a vertex had a different weight than others…BUT there are no vertices in those areas…!?

I checked for doubles duplicates scale , etc. ??

The way to fix it is to Dissolve those edges, and then make a new knife cut where they were and then you can paint those areas using Mix…

I think joseph was closer to spot on than I was. Looks like you just used a small image, 512 maybe, to paint on. I went to the Paint window where the image is on the left, scrolled into the line of dots, then when up to the Stroke tab and changed the spacing to 1% instead of 10% and I was able to fill in the white spots with blue. See if that works. IDK how to add an image here in my post (I’m a noob to this forum - and forums in general) or I’d show you a screenshot. :slight_smile:
Let me know if it works.

1 Like

I haven’t tried your solution but sounds like it is right on…and easier to do :wink:

as far as images…take your screenshot and drag and drop it into the post.
Have you finished the New User Tutorial (The first message you received here from the Bot ) gives you more access to do things! Go do it!

1 Like

No I haven’t even looked at the Tutorial yet, but I’ll be doing that right now. Thank you for the info!

1 Like

Here we go :slight_smile:

1 Like

Good for you! You wouldn’t believe how many don’t do it or continue on and complete the advanced tutorial!

Marked your post as the Solution…Good Find!
Happy Blending!