Texture paint not refreshing in the view port. How annoying !

Hello every one.

It seems no single day goes by without me needing your help ! This time i struggle with texture painting. Oddly enough, I used to be a bit capable in this field, but I am stuck today !

The situation is the following:
I have several UV layouts for my objet: a “target” one and 2 source ones.
I want to clone from the sources to the target.

So I have created a blank image associated with the target one, and I start to use the texture paint mode and the clone brush, having selected the “target” UV as active and one of the 2 UV sources as well, source.

But the image I am painting is not updated in the viewport until I toggle to Object mode !
So I don’t have instant feedback of what I am doing !

I have tried changing to GLSL, Multitexture, Single texture (what are this things anyway ??? I can’t find anything in the Wiki) without success.

I usually work in Cycles mode, but sometimes it is better to switch to Blender Render mode.
None of them work this time.

Have you ever encountered this ?


yes. Texture painting with multiple UV maps creates a delay in viewport texture display. Same as you, I found out that toggling to object mode and back fixes it but the lack of interactivity is annoying. This may deserve a bug report ?

I encoutered this problem on a Mac and never tried again on different software/hardware. So it might be platform-specific. If you decide to report it you should include graphics card and OS info.


Considering single texture was removed last november, try using a more recent version of Blender.

I gave a test to paint with cloning on an UV from another UV in texture paint mode on a mesh and everything worked for me in 2.70 , i didn’t needed to go to Object mode to see my cloning update in real time .

Now to check if you’re not missing something in your process, here’s a step by step example so you can check if there’s something you’re doing wrong

I’m using Blender Render mode , Multitexture and Solid shading (as the texture paint automatically will texture solid the display) for this example

I have Uvmap1 that has my model unwrapped to the texture i want to be the final one, so far a black image

I have Uvmap2 that use another image and will be a cloning source

I have Uvmap3, another cloning source

In the UV list, select Uvmap1 as it’s our final result, it’s on this one we’ll paint
Now go to Texture Paint Mode and select the Clone brush

In the Options tab, enable “Clone from UV Map” and in the drop down list, select Uvmap2

Start paint-cloning

Now in the drop down menu list, select this time Uvmap3

start paint-cloning

If you’re doing those exact steps and still have the need to switch to Object mode, you should really report it on the bug tracker, maybe it’s something OS/hardware specific (on my XP system i have no such problem, everything is responsive without display delay or need to switch to Object mode) that the devs should know

Thanks both of you, especially Sanctuary for taking the time to make this little tutorial !

First of all, I use Blender 2.69: I have noticed some bugs with 2.70 and I don;t like the tabs, so I haven’t made the switch so far.
In 2.69, Single texture is still here.

I have followed your step carefully, and it works absolutely fine ! In fact I knew I could do it properly: I managed it pretty well when i was making my violin.

Oddly enough it simply doesn’t work with my other file… although I am pretty sure I do the things as one should: it simply doesn’t refresh in real time. At first i thought it had something to do with me working on 2 monitors, and thus with 2 windows of blender, with the UV image editor in a window of its own. I thought there might be a sort of limitation due to openGL not sharing the same window or things like that. But it isn’t so simple. There must be something screwed up in there: path to the texture, dependencies, or anything.
I have tried with 2.70, and while single texture is away it doesn’t work better…

I will try to trak the bug and replicate it with minimal number of steps.

While I am at it. Maybe you could explain what the “stencil” layer does ? I couldn’t figure it out yet…

Thanks Sanctuary: you are obviously very good at explaining clearly !
I was refering to the one in the option tab however. Nevermind, I’ll figure it out myself some day.

Back to my problem:
I closed Blender, took a break and it worked fine.
And after a while it broke again.
So i stopped Blender and restarted it, and it still doesn’t work… There is something odd going on…

Does this happen on a simple cube too, or is it on a specific blend/textures ?

If it only happens on a specific blend/textures, you should report it on the bug tracker, with the blend of course.

I’ve been trying on the default cube to replicate the bug, but i couldn’t.

I will use my blend and simplify it (quite a lot going on…) to isolate the trouble and report it when it is sure that someone can replicate it.

@Sanctuary: I’ve made some test regarding the Stencil option and it is very simple in fact.
It is a sort of “texture mask” but it is UV based instead of screen-based.

Imagine you have 2 UV maps with images assigned on: one of them is your target blank image and the second one is a black and white checker pattern.
You want your target UV map and image to be active, you choose a brush, say a normal paint brush with a red color.
If you activate that option specifying the UV layer with the BW checker as a stencil, when you paint it’ll only affect the areas of the mesh that are white when using the source/checker pattern UV map.

BTW I filed a bug report because the texture masks ans textures brushes don’t appear correctly on my system but completely noisy:

Alas I still couldn’t find a way to replicate bad refreshing behaviour with my other file. The fact that Hadriscus suffered it as well makes me think it’s not due to my file but to some sequence of events that lead to this bug…