Texture Paint, not showing the effect of painting


I would like to find out why is it that the purple object is not reflecting my image on the left in Texture Paint.

It appear okay in shading and my nodes were correct,

What am I missing? Thank you for your advise in advance!

I believe you need to save the texture file somewhere on your computer and then open that file from the location you’ve saved it in the shading workspace. Your doughnut is purple in color as it is not saved anywhere on your computer.

Hi Rambunctious,

Thanks for your reply. I have already saved it. As you can see in the image. It is called “donut_Texture”.

I meant to say that you need to save it by clicking on Image and save it somewhere on your computer. It looks like it is unsaved as there is an asterisk next to Image. If you have overwritten your previous save, you can use the hotkey, Alt + S, to update the saved file.

Thanks., howeverI have checked that it is saved on my PC. It was not the issue

Is it working now?

Nope its still not. I think i might have to recreate it.

Did you replace the image texture in the Image Texture node in shading?

For texture paint you need to UV unwrap the model. It doesn’t look like you unwrapped it yet.

Looks Like you missed the first step and didn’t add a texture slot…


Hi guys,

Thanks so much for your all your help. I decided to recreate the node and it work now. Appreciate you all!

1 Like

Yes, I have already assign the image but it still didn’t work. I figure that i should just recreate the node and Voila! It works.

Thanks, I followed Blender Guru, he mentioned that in this case. Unwrapping is not necessary. I wonder what does unwrapping do. Will check it out soon. Thank you.

All imported base objects > Plane, Torus, Cube, Etc already have a created UV map ( check box in the drop-down on left Bottom side…so it is not needed to un-wrap…That said, it is sometimes, if not in all cases, better to do your own un-wrapping to eliminate stretching and unwanted seams. If it is an imported object then it may or may not have a UV map, so you can do your own or use the check box in the texture paint settings to add a basic UV. It is usually pretty badly done on an imported object, like a character file, so better to do your own. It also allows you to add a PBR texture a lot better as you can duplicate areas to eliminate texture jumps at seam areas…painting on the UV itself and moving islands to match edges.

1 Like

Thank you for the informative reply!