Texture paint not showing?

Hey I just started using blender, it;s great but the interface is really confusing.
I managed to get two textures on a uv sphere: one is an image, and the other one is texture paint. The problem is that the image layer I think is just covering the other one, is there a way I can just draw some red spots over the image to show up? Thanks!

Hi,

It sounds like you would need to use uv mapping to do what you are after.

Attached is a blend file with 2 uv maps on it. The first is a check texture. The second it a uv texture with red dots on it. Those polka dots are then painted on using Texture Paint mode (I painted a little smile face to show its effect). The dots don’t over write the image underneath (the checks), because they have alpha values for everything that is not a dot set to 0. I also had to make sure that in the Image Sampling panel that the Use Alpha option was ticked.

Hopefully you can pick apart the attached blend file and see how it was done :slight_smile:

If you are using 2.4x version of Blender then the same techniques apply.

Attachments

Blender 2.56 - Image Texture and Texture Paint UVSphere.blend (653 KB)