Texture paint won't texture everything?

Hello, I’m fairly new to animating so I’m kind of a noob so keep that in mind!
I’m Dutch and I discover a lot of new vocabulary here…
Anyway: I’m modeling, texturing and will be rigging a bird but I got a little problem with the texturing.
I first added just the feather’s texture via UV-mapping and that went fine but now I want change the eyes and its beak since it would be kind of weird seeing feathers on those things…
I went to Texture Paint and started painting the beak yellow and the eyes black (and making the rest of the bird a little bit nicer) but it won’t texture some parts.
In this picture you see I can’t make the top of the beak yellow while going over it with my brush:
http://s14.postimg.org/70pfetev3/blender_bird_fail.png
Anyone know how to fix this? Please help!
Thanks.

Could you upload an image of the the UV map (or maybe even the .blend file)? Are there any UV islands that overlap or are too close?

I’m taking a wild guess and saying you have the bird mirrored? That can cause some texture oddities along edges if it’s set to merge. Try applying the modifier and then going into edit mode, press “W”, and select Remove Doubles. Then try painting. That should make it one seamless mesh. (I don’t think you’d need to re-unwrap it, but that might be something to consider if it’s still having problems.)

Judging from that image I would have to along with skywolfblue. One bit of information, that you might already know is that texture painting depends of the angle of the face you are painting in your viewport. For best results try to paint on the faces, when the normal “point right at you”.

I’ve came to a different problem: After painting on my model, I save the file and close. But when I re-open it, all the painting disappeared?
I’m not able to test what you’ve said here atm but I can give you the .blend file: http://dl.dropbox.com/u/89595363/bird.blend
(Yes, there are some unnecessary lamps). Though when I look at the file in windows explorer I can see the painting on the picture of the file.

Ok, I painted it yellow to show which areas are showing up or causing problems.

Immediately, I can see that:

  1. You need to clean up your mesh. The part where the beak meets the rest of the head needs to have some of those really close vertices merged. And you need to delete the unused interior faces, they’ll mess up your smoothing, UV’s, and lots of stuff.



  1. Redo the UV unwrap. Make sure that it fits inside the bounds of the UV area.

As to it not saving:

You need to save out your texture painting to an image, I don’t think blender keeps painting stored in the file. In the UV window, click on Image > Save as Image and give it a name like “Bird_paint_1.jpg”. Then use that saved image as the texture.


The texture of the ‘feathers’ of the bird is nicely placed in my opinion so I don’t want to change that, but with texture painting I wanted it to look nicer. So here is what I did now:

  1. I added a new UV map called ‘bird transparent’ with a fully transparent picture
  2. I went in edit mode and unwrapped the bird (it fits in the UV area now, so I shouldn’t have that problem of not being able to draw on everything).
  3. I went to texture paint and started painting everything yellow to see how it goes, I still kinda have places I can’t paint but I guess that has to do with the interior faces.
    Before these steps I was testing some stuff and I created a few UV maps and I don’t know how to remove them.
    After these steps I found out what you mean with ‘delete the unused interior faces’, that’s why I didn’t try that first.
    I think I don’t really know what you mean with ‘cleaning my mesh’.
    If I remove the interior faces, will that mess up the feather textures? (bird6.png)
    I’m also wondering how I can see these painted textures in the render, do I have to do something with the material/textures tab?
    By the way, the remove doubles didn’t really do anything. But I’d like to know how I can remove the other half of my bird for easier painting.
    As you see it takes me a while to understand all this new vocabulary I see with blender since English isn’t my primary language.
    I’ll try removing the interior faces once I know if it messes up my feather textures and how I remove the unused UV maps I created from that list.

Here’s another screenshot for you if you don’t really understand my explanation:
http://s2.postimg.org/4ews7kqt3/blenderscreenshot.png

Here are some further tips:
Personally I prefer to have only one material per object. In your case that would mean one object for the bird body with the feathers and another with the painted beak and eyes. The mesh can easily be split by selecting all the vertices, that belong to your body and hit P -> by Selection. That will separate all selected vertices into a separate object. Guessing from you screenshots, I guess, the body is a continuous mesh anyway, if that’s the case you can select on vertex and with Ctrl+L select all vertices that are connected.
What skywolfblue meant with cleaning up the mesh is, that the number of vertices is reduced mainly by merging nearby vertices into on (select all and hit Alt+M)
For easier painting you can also hide some faces (H) (unhide is Alt+H). In Texture Paint mode you can do this when Face select mode is active:

Attachments


I worked a bit further on the bird and these are the results:
I removed the interior geometry and there isn’t bad mesh geometry any more :slight_smile:
I didn’t split everything in multiple objects like hotzst suggested though.
I had to redo the feather texture of course and it worked out quite nicely.
But because I didn’t like the wings I selected them in Edit mode and used the button ‘E’ to replace the vertexes on the UV map which made it look nice again.
With some texture painting magic I removed the rough borders from the wings.
Painting the eye worked out quite well.

But then I got to the beak:
-Texture paint still won’t let me texture the top of the beak.
-Because I hit ‘E’ on the wings some faces of the beak were mixed with the ones of the wings and that left weird yellow marks on the wings.

Why it won’t let me texture the top of the beak is still a mystery for me, does anyone know?
I could fix the problem of the mixed faces by adding an extra UV map for the beak only but I don’t know how I would do that ('cause I probably need to do something with transparency). If anyone would give me steps on how to do that it would be greatly appreciated :slight_smile:

I also ran into another problem with rendering:
Left-under the eye it looks different on the render than in the project as you can see here:





It has nothing to with the places of lamps as I tested out.
(On a side note: When I render I can’t find the image in the selected output map nor the tmp map, I had to use screen shots here. What did I do wrong?)
You can download my .blend here: http://dl.dropbox.com/u/89595363/bird.blend

Anyway, thanks a lot for how you guys helped me already. I learned a few new things :slight_smile:

EDIT: I forgot to say I also split the object in half and removed the other part, but I think that isn’t that important.

  • Go into edit mode.
  • Switch to Vertex selection (Ctrl-Tab).
  • Select the vertex that’s at the top where the beak meets the head. Zoom way in. You’ll notice you’ve got two vertices’s really close together. This is the problem.
  • There are 3 ways to fix it:
  1. When you go to do a “Remove Doubles” you should see a Merge Distance field in the operator section of the toolbar. A higher threshold means a larger area gets merged. (you want to make it large enough to merge everything too small to see, but not enough to merge any important mesh details)
  2. Select both vertices, press W and select Merge.
  3. Turn on snapping to nearest vertex and translate one of the vertices until it “snaps” onto the other (http://wiki.blender.org/index.php/Doc:2.6/Manual/3D_interaction/Transform_Control/Snap). Then remove doubles afterwards.

The bottom of the beak also has the same problem.

I used the merge method, really thanks a lot :smiley:
I got the beak to be yellow only by having it as a different object and having its material to be yellow :slight_smile:
Then I joined the two objects, I did ALT+D, CTRL+M and Y. Now I joined the two halfs of the bird and I can finally rig it :slight_smile:
Only problem left is why my rendered file doesn’t appear in the selected output.
And I also have the tiny problem that my bird gets displayed weird in blender itself.


Again, thanks a lot.