Texture Painting Issue


I’m new to Blender. I am following a tutorial I found on youtube called “Blender for Beginners: Easy Froggy!”, and there is a part where they show you how to use the texture paint. I’m following it and I realized that my material under the texture slots looks weird. It looks greyed out, as if it’s not activated. In the tutorial, it looks highlighted. When I go to use the fill bucket on the frog’s head, its color doesn’t change. Would anyone know what I could’ve done wrong? I tried going over the steps a second time but the same thing happened. I have a screenshot of my issue below.

Thank you!

Hello and welcome!

I find that all my textures greyed out as well, but this doesn’t appear to mean anything - I can paint on them. Maybe it’s some cosmetic bug? I can’t remember if I ever saw those lines “active” :thinking: Hopefully someone will know.

On the other hand you have Paint Mask activated (that blue square icon in the left upper corner, next to Modes menu). It only lets you paint on faces that are selected (in Edit or Paint modes). And if none selected than the whole thing is masked and it won’t let you paint.
Try disabling it and see if it solves the issue.


Yep, the faded ones are masked. :+1:

Hello, :slightly_smiling_face:
Sorry to bother you with the same issue. I was wondering if you found a solution to the problem. I am doing Donuts Tutorial from Blender Guru and same greyed slot at texture painting. It happened to Paint well, but then in the Geometry nodes, appears a greyed slot and missing options so I cant move foward on the tutorial.

I will add the image. Thank you in advance.

First off…I hope you saved your images…as in the screenshot you had not saved them as yet…( Asterix next to Image in the Paint Panel) if you don’t you lose them if shut-down!

We need to see your geometry nodes since you say that is where the problem is…( The panel you circled does not look greyed out from this image)…