Texture painting looks low rez

hey blender heads

ok made a whip and got a snake skin texture and went into texture painting, using stencil mode and painted the snake skin onto the whip and looks great BUT when I got back into object mode it looks terrible???

I have unwrapped the model of the whip and the texture I choose 2048 as size.

Like I said it looks fantastic in the texture paint mode so why doesn’t it look that good in object mode??

sure I am missing out a step somewhere…

thanks for any help

If I add a cube or sphere and add the snake texture it’s fine.
If I make a long stick then the texture is stretched and low res.
I tried to make the stick in sections and texture each part but still no luck.

Any ideas please?

Did you check the UV-Mapping?

How big is the texture you’re painting onto? How big is the mesh for it? Screenshots please?

If the results look good in the image editor but not in the 3D viewport, then check these settings:

viewtexres

specifically, the Limit Size option. See if it looks better set to a higher value or turned off.

Otherwise, as has been said, make sure your unwrap uses a sufficient area of your image. A huge texture won’t help if your unwrap is crammed into a tiny portion of it, and having a hi-res stencil image won’t mitigate this (if it’s getting baked down into a small unwrap at paint-time).

Thank you very much for all the replies. Will double check later with some of your answers.