Texture painting - model shading issue

Hi
Just a quick question. I have problems using the texture painting function in that the 3D viewport shading of the model is too dark to actually see when painting on the model (textured shading applied). I tried changing the default lamp to a sun and hemisphere light as I thought that might be the problem, but no luck. Can anyone please advise me on how to brighten up the shaded model so I can actually see where I’m painting.
Thanks
E

Look in the User preferences-> System and OpenGL tab. To the left are your OpenGL (modeling) lights. Try changing the colors of these to something brighter.

Thanks, will give it a try