Texture Paint's odd behaviour

Hey guys,
I was trying to Texture a Model of the “Ape King” for an University project.

Well as I came to Texture painting something odd happend.
As I tried to use the brand new “fill”-brush (blender 2.72) in the 3D viewthe former brown color turned to red and I get weird stripes all over the Model.
So I tried to color it manually with the ordinary brush. The color remained brown, but when I touch areas like the face or wrists these annoying and frustrating stripes appear.

Since this is stopping me from finishing the textures (which I actually needed tomorrow morning) I was hoping you could help me.

here’s a screenshot:and the .blend file https://drive.google.com/#folders/0B9NyB1Nos5iLXzY1cEN1cExsUm8

Your link gives

Unable to access folder with ID: 0ADnKZxoP1i3jUk9PVA. Check access permissions on the folder.

Please supply a valid link to a shared file
Do you have overlapping uvs ?

I don’t think so, when I smart-unwrap it the issue stays the same.

The link should be working now :slight_smile:

Edit: Apparently the color draws a line to the teeth-uv for no apparent reason

I reworked the whole unwrap (not the screenshot above), now everything is without overlapping (itself) but the issue remains

It seems like the the Uvs have nothing to do wiht one another (like finer and kneecap) but when I paint the finger the UV directly beside it seems to be affected because the brush even paints out of the UVs-boundaris… how can I switch that off?
Here’s a picture of it (I painted in the 3D view)

I suspect your problem may relate to n-gons, but the link you gave requires me to register an account with google drive in order to access the file, so I cannot say for sure. You may wish to use instead a server such as pasteall.

Here you go (I shouldn’t have a single n-gon)

I think this is a problem of having the brush’s bleed size too high… While in ‘Texture Paint mode’, in the ‘Tool Shelf’, tab ‘Options’, subtab ‘Project Paint’ set the ‘Bleed’ value lower.

Thanks! Seems to be solved so far. I’ll write again if any problem occurs :slight_smile:

Well I still get those strange lines:

I tried to download the blend, but it looks like the bandwidth is being metered, and at the moment, it won’t download. Anyway, I think you should check the ears, to make sure you’re not missing some n-gons.

There are 10 ngons on that mesh.
unselect all, click on Select -> Select Faces by Side
press F6 (or look into Operator panel on bottom of toolshelf, to the 3Dview left) and change the default “Equal To” to “Greater than” , so Blender will select only faces with more than 4 vertices (that are ngons)
And you’ll have your 10 ngons selected.

Ok, I got the blend ( clicked the wrong link last time ) … In addition to the n-gon issue, you need to put another seam around the ear. I will check for other issues…
(edit) There are some ‘bad quads’ here and there. When you bend a quad face too much, blender has problems shading it, because it doesn’t know which way to calculate the angles. a good example is the face on his loincloth thingy that bends behind itself. there’s another on his horns. This might also be causing problems with the UV unwrapping.