Texture Puzzle

I have a puzzle concerning texturing and can’t figure out what’s happening. I’m running blender 2.70a. I’ve textured a sphere with a map of the earth. When looking at the sphere in the 3D view or through the camera, the map replicates itself on opposite hemispheres and smears out in other areas. Yet, if I render an image of the oddly textured sphere, the rendered sphere looks as I expected it should – namely just like a globe. The render shows no indication of replication on opposite hemispheres. Also, the render does not display what I see through the camera view. I can set the view to, for example, Africa and the render shows Anartica.

The first image below is what I see through the camera. The second is a render of the camera view. What do you think? I must be missing something simple.

Here is the blend:

You have no UV coordinates for the sphere. So the viewport display is off. Also you have selected generated spherical coordinates for the texture which is why the render looks ok. But as you are finding out it becomes difficult to setup your final shot if you can’t really see what your final render is going to look like.

To solve this you want to add UV coordinates to the sphere by putting it in edit mode and choosing one of the unwrap options. After you have UV coordinates then you need to alter the texture on the material to use those UV coordinates instead of the generated spherical layout. After making those changes your scene works as expected.

There are quite a few video tutorials on the subject of UV unwrap, especially planet making in general, check em out on youtube or vimeo. (or blendercookie.com)


27_EarthTexture_UVs_Installed.blend (118 KB)

Thanks for the input Atom. I should have said that I was following Andrew Price’s tutorial called, “Realistic Earth”. He didn’t use UV and the “globe” mapping was perfect. It’s kind of cool check : http://vimeo.com/25078416 and you can see what he’s doing from 7:00 through about 7:36. My mapping certainly didn’t turn out like his, though. Hmmm, upon reviewing that tutorial, I note that he is rendering all the time. I don’t see any mapping when he switches to 3D view.