texture seams visible when exporting to collada (.dae) or JSON (.js) format

hi,
i have encountered frustrating problem with my model, when exporting to .dae or .js format:
texture seams become visible, even though in blender everything seems to be ok
here are some screenshots with the problem description: http://imgur.com/a/1Hynf#0
browse through screenshots to see the problem im trying to figure out
am i doing something wrong? because it happens with two different exporters (collada and json, when trying to render with three.js webgl and other environments as well)
so it isnt external viewer issue

any ideas?

It is possible you are using smaller textures for webgl? Filtering is a bitch if you don’t take enough care with the edge padding on different resolutions: http://wiki.polycount.com/EdgePadding

Within Blender you can Bake the texture with a big enough “margin” value to fix the issue on smaller sizes.

If you use Windows & PS you can download xNormal, as it has a nice Dilation plugin for PS.

thanks for your reply
i’ve been thinking about filtering being responsible for this as well, it seems that might be the problem, however it’s very weird, since i use the very same image files for blender and other software renders, i even tried to tweak my graphic card settings for texture filtering, but the problem persists

following your suggestion i installed xnormal and loaded that model with the same texture file (with .fbx exporter this time, to make sure it isnt exporter related) and look what happens when i use GLSL rendering in xnormal viewer: http://imgur.com/a/nbDWG#0
seams show up only when i move away from the model, so i guess it is caused by wrong filtering (but why does blender render it properly in GLSL mode then?) and the question is if it is gpu driver related, or what else is causing this…

i will have to try that xnormal filter in ps i guess, but it really bothers me that blender shows me no issues, and other software cant render it right

As it is stated somewhere on the polycount wiki page it depends on each engine, filtering type and mip map mode.

In blender, maybe you got Anisotropic Filter active, which makes the issue less evident.
Or maybe you don’t have mipmaps active, that is a seam killer as there is no filtering at all.

Anyway… I’m not sure, but I think you can override the filtering settings on your GPU driver control panel, so all apps use anisotropic filtering. But if you are going to release a game, some users might not have the same settings, so the best thing to do is to dilate the edges enough to prevent the worst case.

you are probably right
and sure i could override mipmap and filtering settings, but i want to be sure nobody would see the seams, no matter what hardware and settings they used

ill go with that dilate plugin then, thanks for suggestion and clarification, cheers