Texture size in Cycles

How do you change the texture size in Cycles? I’ve been trying different orders of this node setup but to no avail. I noticed that the difference in order changes the effect drastically.

Is this what I should be doing? Or should I revert to BI then come back into Cycles?

Thanks!

Attachments


Wow, that was fast! But it didn’t work quite though. The normal texture without any translation / scale works just fine. However, connecting the Mapping node gives me a blank texture, with the basic color of the overall image. Adjusting the settings of the node seems to change the RGB values- nothing in terms of scale or so.

Any ideas?

Attachments



Again i suggest you look at the link i posted all your answers are there.
You are missing a texure coordinates node. the mapping nodes doesnt have any coordinates to work with.
So add a texture coordinates node before the mapping node

Here:


+1 for the link DDD posted above. I’m learning a ton going through those posts.

Thanks DDD and benu, that setup worked! Now gotta figure out using a bump for the same.

Yes it seems obvious now but blue connectors go to blue connectors etc. You should be led by the colour coding of the connectors.