Texture Space manipulation in Blender 2.5

Earlier this week I was having issues with mapping textures to text objects converted from curves. http://blenderartists.org/forum/showthread.php?t=183173

The simple method to fix the issue was to use Blender 2.49, select the object and press “T” to bring up the the Texture Space menu. Where you can then manipulate/scale the texture space to suite your needs. This is down the page here:

Problem is that I’ve been trying to use 2.5 so that I know it’s interface. I know that 2.5 is just in development still and not production ready. But I’d love to know how to achieve this this same manipulation in Blender 2.5 now that the key “T” has been changed (for the better!) to Tools.

I also know that I can fool around with the texture mapping and coordinates to achieve a similar result. But considering that I often use multiple textures in a material, it’s a pretty tedious experimentation process changing the x-axis scaling of 4 textures to see how it turns out.

And maybe the way I’m going about this is now antiquated? If so, does anyone have another suggestion of a better technique that I should be using. I’d like to use text and objects converted from curves with materials that have textures that map correctly to the faces. Which doesn’t seem to happen on anything converted from curves.

Thanks in advance for any advice!

I’m also very interested if someone has a solution here.

Another note, I have been able to get around this by saving the file from 2.5 and opening in 2.49. Then I adjust the texture space save the file in 2.49, then reopen in 2.5 and voilà, texture space resized.

I’ve combed through lots of different places looking for this, I’m assuming it just hasn’t been implemented into 2.5 yet. Anyone confirm that?

Sounds like your mapping to ob or global coordinates? uv texture maps shouldnt be distorted with objects converted from curves. if you are cant yous cale the object and the material scale will stay the same? it seems there is no tool for sclaing texspace yet unless it is hidden deeply…have you looked through all the hotkeys? Mabe you should try to find the operator and make a very simple script to do this.

I have been looking for something like this in Blender for ages, thank you por pointing me in the right dirction!! The texture space manipulation is now shift+T. The texture space can be moved and scaled, I couldn’t find a way to rotate it.

Was trying to do this type of mapping but “object” doesen’t seem to work well, appears and dissapears by own will in complex scenes, global/cube does not map on a cube and the uv projector modifier doesen’t work either with more than one projector (that is, trying to map something like a building with bricks), but the texture space seems to work, hooray!

where do you use this Shit-T thing
is it on curve object with texture

or is it on mesh object ?

also you can always add an empty and then you can rotate scale or move your texture!
and can be animated too


I used it on a mesh object in object mode, but seems to work on curve too (I didn’t test it)

Wish there was a way to rotate the texture space too.

Thanks, I will try the empty. I was using a cube as the mapping “object” and I got wierd results: seemed to map ok up to a point and then I made some change to a totaly different part of the scene or to the “object” scale and the mapping goes all wrong. Hope the empty works better.

Later edit:
tried the empty but it just doesen’t work right. Maybe I’m missing something? I set the mapping to object, cube (tried flat also but same results) and select the empty. I also tried to child the empty to the mapped mesh, no result. It renders correctly at first but after I scale the empty or rotate it my mapping begins to go berserk. It can also go wild if I change something else in the scene, like change the camera. Looks like a bug that acts in a random fashion? It was the same in the beta version.

The space texture seems stable so I’ll use it for now but the object mapping would be much more flexible as you say… if it worked :frowning:
Nobody seems to be complaining about this so maybe it’s me?

here is a link to my tests: https://picasaweb.google.com/101670300710506134321/EmptyMappingTesting?authkey=Gv1sRgCK-vvf2PrOyJYQ#

i tried shift T in 36326 and don’t seems to work?

where do you see to modify the space here

is it in one of the panel may be?

here is file with sample for empty and seems to work fine for me


I use the official version, 36339. You have to check “texture space” in object properties-display first, and it shows like a dotted box. If you try it on a cube you won’t see it as it overlaps the object but if you hit shift+T it will move around. I can use grab and scale and the axis constraints.

Thanks for the sample, I will study it tomorrow as my blending time has run out for today :slight_smile:

sorry never use that one in 2.5!
i tried what you said and cannot see anything moving on a cube!LOL

don’t know i can see a texture space in texture panel and also object mode and treid the 2
but don’t seem to work
anyway i’ll try again tomorrow with the latest built and see if i can make it work in 2.57

i know how it works in 2.49 but 2.5 !

but the empty shoudl work nicely and give access to all 3 values rotation scale and location


I tried your test file and the fact is you used a cube and procedural texture. I think porcedurals being 3d don’t show the bug I’m talking about. I get it using 2d image textures on some walls with openings and it appears totally random, making it difficult to test (meaning it can appear when I think all is ready and pressing render for the nice final image). I am attaching a sample file. I used a colored test map so the result is more clear, in practice I need to apply materials like bricks or plaster. Sometimes I would need to scale the empty say, only on the z axis.

empty-test02.blend (647 KB)

Thank you for taking the trouble!

Here is also your test on which I scaled the texture space, does it show in your blender?

texturespace-scaled.blend (379 KB)

one thng for brick if you need to set different parameters like joints height brick height width ect.
you can use texture brick node which allows to do that!

i’ll play later with your sample file to test that

for the last file i can now see the dotted box in viewport which is the text space in 2.57
but i tried the shift T and it does not change it like in 2.49

how do you change it ?
or is ther another keys to work with this?


for the test2 file with house

i don’t see any UV mapping here?
did you use UV mapping at all?

on a complex shape like a house you need to set some seams and unwrap it an apply a UV map texture to control how it will appear on your different walls!

i mean don’t expect to be able to apply a simple procedural texture and control it on complex 3D objects!

the way to go here is with UV mapping i think!

unless you have a simple general procedural texture like noise or something very simple where you don’t need to control the texture very pecisely!

have fun with texture

I didn’t go far into material nodes yet but I’ll have to check these bricks, thanks!

I just press shift+T and the dotted box starts moving with the mouse movement… no ideea why it’s not working for you. Try alternatives like ctrl+T, maybe the keys are mapped differently?

Blender is complex :slight_smile:

Yes, I was afraid I would get the UV answer :slight_smile:
First to make it clear: I can UV map rather well now, using seams or different unwrapping settings, and I used it on particular objects.
My problem is that I use Blender in architectural visualisation and the needs for texturing are very different here than for texturing say, scenery for 3d art. The later would use detailed texturing on buildings, showing for instance cracked plaster or wear, and Uv mapping is usefull for textures on large areas. In arch viz UV mapping a complex building is a mess and doesen’t suit the purpose. I mostly use tilable 2d textures depicting exact materials, to exact specs, like ,say, wooden panels 30x10cm. Uv mapping is not exact for such purpose, you have to scale the uv approximately and also the unwrapping tools are difficult to use: the unwrap often comes with distortions and a complex building with many openingsis difficult to “seam”, the cube projection doesen’t do the job well, project from view is good but you work a lot to select different sets of faces etc. Not mentioning that an archviz project can change a lot during work and with UV mapping you have to redo the unwrapping if you alter the mesh.
Instead, the simple mapping xyz using the texture space is just great for the purpose. For the house model I posted for instance, though the object seems complex, the mapping required is just a tiled plaster 3d map (I have some that tile rather well without showing the tiling), using the generated mapping and scaling the texture space is the best way to go. The object mapping would be even better if it worked.

I hope I make sense. this is something you probably understand better when you actually have to do it…

yes mapping with UV gives the best and you have the total control over where it goes angle ect…

but usually done after the model is completed
mind you you could use UV island which are basically independants of each other
so you can modify different parts ofn a 3D model without affecting other parts in the UV mapping!

in your house file i can see that you use an image like arrow and appied it as a cube mapping

but this won’t work well on complex 3D model or offer a lot of control
you can probably move or rotate it a little but it’s more difficult to control then using UV mapping

on the other end if it is simple procedural mapping then you could define different materials for different part like a wall rectangular then apply a simple wood image on it or a plastered wall with a procedurale texture

i think that can be done relatively well and in 2.5 you have a much higher limit for quantity of material up to over 32000
in 2.49 this limit was at 16 material only

so if you use multiple material for relatively simple shape likie rectangles or circile
you could apply simple procedural textures per material and get good results!

Thanks for the suggestions, I will look more into using procedurals. We have strayed from the topic though :slight_smile: After the technical explanations in my last post I will now have to solemnly swear that based on actual tests generated mapping worked better for that model than UV :slight_smile: So, if I will be so stubborn and hope to use object mapping… why does it not work as it should? The object has just 90dg angles, faces nicely aligned to the xyz coordinates, mapping it with an empty or a cube as a “mapping gizmo” should project the mapping on the faces the same way, no matter it’s a simple or complex object. (like generated mapping does). It should be mathematical, I don’t think Blender is saying “oh this is too complex, I’m scared”. I think it’s a bug, but I never reported bugs and don’t know how…

[ATTACH=CONFIG]138850[/ATTACH]you can use simple mapping but it does not offers control over independant parts of the model

and in mapping panel you can specify scale or location for X Y and Z and it may work for a simple case

but if you really need a lot of different texture on different part you better off with UV mapping or using multiple materials on different parts
and for bricks you could use the texture brick nodes
see a tut on this at blenderguru i think
i’ lost the link i’ll try to find it again later

ok here is a file for bricks texture node


just render it and it should give a nice brick wall
with lot’s of control over the mat and brick size too!

and should also work in 2.5 i think if not let me know i have a 2.5 file too

Thanks, what quick answer :slight_smile: I will certainly use this


for tut on bricks node