Texture Splatting not working...?

Hello all,

So, every now and again, Blender will seem to do something that completely stumps me, by refusing to work - even when I’ve successfully done it in the past.

This time around, it’s texture splatting for the game engine.

I’ve followed a number of tutorials on it, a couple video tutorials on Vimeo and one in web-page format with screenshots of each step. I’ve followed them all to the letter and detail, but it’s just not working.

My system is very much GLSL capable and it is enabled, so that’s not the problem.

As anyone who’s worked with, or does work with that system is aware, you set up a UV-mapped black texture as a “stencil” image which is used to paint the visibility/transparency between the layers. That’s the point where I’m having the trouble.

I have all the bases covered…

  • solid black image created and saved

  • UV-mapped to the object on the 2nd texture layer of the material

  • ‘Color’ is disabled

  • ‘Stencil’ is checked

  • ‘RGB To Intensity’ is checked

  • ‘Color’ is set to Black

  • I’m painting to the Stencil image with that texture layer selected

  • I have GLSL enabled.

  • I have tried the Blender Game Renderer and the Blender Render setting, neither makes a difference

  • I’m in Textured Solid mode.

  • The stencil is enabled in the texture list.

  • I have my first and last (third) texture images set on their own texture layers, above and below the stencil image respectively

Despite all that, the Stencil image is not doing its job. If my layers are set up as such:

  • Grass
  • Stencil
  • Dirt

Then with everything set up, I should be seeing the grass until I begin painting white onto the Stencil, which will cause the Dirt texture to show up. But it’s not. The object is entirely filled with the Dirt texture, as though the Stencil image isn’t there at all.

When I paint on the Stencil image, it shows in white where I’m painting in the UV window, but nothing is happening on the object itself.

Soooo… after trying this three different times, with the same results, I’ve finally thrown my hands up in the air and decided to come here to see if anyone has any idea of what it might be that’s going on?

Last time I tried it was with 2.49, and it worked fine. Now I’m running with 2.6 (latest build) and no dice. :ba:

Any help is appreciated!

While I’m thinking about it, and before I crash for the night, here’s a zip file with my blend file and all the textures used. If someone would like to give it a look and let me know if they see anything wrong, I’d appreciate it.

I’ve done this thing over another 7 or 8 times since my last post and it’s still not working. It’s driving me nuts at this point.

Here’s The Files

Thanks :slight_smile:

You need to specify the actual stencil image that you’re painting as the source image in the Stencil texture slot. The “Stencil” texture isn’t pointing to an image.

Ooooookay. I see what it was now.

That’s so odd, because I don’t recall anyone in any of the tutorials I’ve followed ever actually having to do that. I mean, when I say I followed the video tutorials and such to the letter, I mean I watched, paused the video, did what they did… resumed the video… paused… did what they did, etc. lol… It was really quite maddening after a while heh.

Very odd.

Okay well that seems to have fixed it then!

Thanks! :slight_smile: