Texture Stencilling in GE *SOLVED*

how can I get this http://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/Landscape_Modeling_II:_Texture_Stenciling
to work with the GE?
here are my files…
http://www.4shared.com/file/33089597/ea887741/maptest.html -a RENDER, but i want my ground texture to look like that in the GE.

http://www.4shared.com/file/33089598/7a376ad0/wtf.html -my material/texture settings.

http://www.4shared.com/file/33089602/496686de/maptest2.html -my blend file

please help!:confused:

-attached files = pictures in second and third link

Attachments



Pack your images and try again.

how do i pack my imgs??

File>PackData

so i decided to show you what a little vertex painting can do. is it perfect or exactly what you wanted, i’d say probably not but its a simple way to make better looking scenes.
this is the blend file of what i got.

http://www.freewebs.com/twoot/maptest2(agntb1u3).blend1.blend

I didnt finish reading the whole tut, however I think I understand.

Go to uv face select and make sure your model is unwrapped. Now add an new blank image, maybe a large one to test it.

Now in the rendering buttons, press bake render meshes and choose the AO ambient occlusion first, and when its done, do it again but choose texture.

Save the image or it will be gone.

If you are using only images, and no procedurals, then I think all you have to do is click use materials in the GE menu? Maybe…

I only use materials to make textures than bake them and use the image for the uvmaping. It works with skin too.

I added a second UV to agentb1u3’s file for some LOD
http://www.weedyworld.co.uk/blender/maptext2tex.blend
(hope you don’t mind agent1bu3)

I wrote a tutorial on how to achieve a similar effect. I think this may help you get the results you wanted: http://blenderartists.org/forum/showthread.php?t=92905

Good luck = )

in responce to itrix’s post. when you use image textures in the geyou should still uv them because if you dont you have no controll over where the texture actualy goes. if your making a single mesh with a whole bunch of textures you can do it all with one material if its all uv maped.

I tried ittitx’s thingy… and the the pic in the thumbnail is what i got… that is the blender GE. So it was a little to shiny so I added a new material, and turned down spectral, and enabled “Tex Face” and it didn’t work. i just need to remove the shiny light now.:spin:

Attachments


just turn specular down in the material settings
[edit] oops, you already did. hmm.

a) make sure hard is all the way up also
b) make sure your light isn’t to close to the ground

upload the new file maybey its something i havnt had a problem with myself and if it arises id like to know how to fix it ahead of time.

How can i have the material settings and the UV image on it at the same time?

make a new material and go to the texture side go to add new it should work, you wont need to set any images or anything there for the game only if you plan to actualy render. oh and dont forrget to set the texture mapping mode to uv.

SOLVED! thank you agentb1u3!