Texture won't get on my plane

As in the the title, I have a texture ready, I can see the texture in the preview in the material buttons tab, but it won’t get on my plane… Or is there anything I still have to do?

Do you have the view port display se to “Textured?”

Yes, one side is just white and the other side is see through …

No one knows how to fix this?

I think to get on a plane these days, you need to pass through security and have a boarding pass.

Tee hee, I just had to…

maybe you could post a .blend file ?

I’m sure most people here could fix this but you’ve not bothered to make it easy for them to do so by attaching your blend to your post. For future reference this makes it so much easier to sort out your particular solution.

Wow!!! That was the best one i’ve heard on this forum!!

I am having a similar problem. I applied my texture to a plane but one side is see-through. When I render it though, both sides have the texture. Normally that wouldn’t be a problem exept for the fact that i’m trying to use it for a game, so working when I render isn’t alot of help…

I already knew about that, but I thought it wasn’t needed because I expected there to be an easy solution :stuck_out_tongue:
The plane is in the file, there is also a green ground plane but that isn’t the one :stuck_out_tongue:

Attachments

CartoonShooter.blend (961 KB)

You have green and small white planes right? They display just fine on my system. Model and texture is good.

Attachments


They work on mine too.

Sorry, that I didn’t reply for so long, anyways, I ment on the grey/white small plane, that is where the texture is supposed to be on, if you select that one you should see a texture under preview too… But it won’t go onto it.

you have to pack the image, the blend you posted is not packed. go to File->External Data->Pack into .blend File. any blend file you put on another computer that has references to external data needs to be packed to work properly.

But just looking at your settings, i think i see the problem:
it seems that you UV mapped it, and put an image texture. only one is needed.
delete the image texture
in the Materials buttons, under the Material tab, should be a button labeled “TexFace.” press it and render. did that do it?

edit: you may want to add some more light to the scene, its kinda dark…

Thanks alot, it works now, but does anyone know why other sides of shapes are see-through in textured view?

I mean, for example on the plane now is the flag, but the other side of the plane is see-through, the same is with the helmet, the outside is just solid, but from the inside you can see through the helmet :confused:

check this: http://blendernewbies.blogspot.com/2009/03/enabling-texture-visibility-on-both.html
that what you mean?

ps: when i do that i hit the “Copy” button afterwards so it copies the twoside setting to all the faces in that mesh…you’ll see it in the screenshot.

That’s exactly what I ment, thank you.
But, do I have to do all the faces seperate?

That will be a huuuuuuuuge job.
Because I have subdivided it multiple times, and I can’t seem to find anyway to make multiple faces at the same time Two-Sides.

youre welcome!

no, thats what the p.s. is for!

check this: http://blendernewbies.blogspot.com/2009/03/enabling-texture-visibility-on-both.html
that what you mean?

ps: when i do that i hit the “Copy” button afterwards so it copies the twoside setting to all the faces in that mesh…you’ll see it in the screenshot.