textured draw type shows white not black

Hey you guys…so um…I have defined a material for my tires as just simple black color and when I go to textured mode draw type I expected to see some black tires. Instead they are drawn as white??? How do I fix this?

Attachments


I have this quite often and it seems to mainly come down to video driver bugs. Do you have an ATI card by chance?

Strangely enough, on one of my computers, I found that the textured and shaded types seem to be reversed, so it could be worth trying shaded and seeing what you get.

Of course it’s also pretty common for it not to be a bug, and for there just to be too much light in the scene. To check this, select any lights in the scene (usually right mouse button on them), go into edit mode (tab) and in the buttons section (where all the option sliders and number boxes are) reduce the energy down. If you can put the energy down to zero on all your lights and still have this, well, you know your problem isn’t too much light. :slight_smile:

If it does seem to be a graphics card problem, make sure that you’re using the latest version of your card’s drivers. If you are using the latest version, ironically, it can sometimes help to go back to an older version.

Hope this helps!

Hey Blendiac:

Thanks for reply-ing. Indeed, the “shaded” and “textured” settings seem to be reversed on my computer as well. So I’m using shaded for textured instead. I notice that the tires seem to be textured black when I’m in “shaded” mode but in “textured” mode they are white but everything else is textured correctly so I guess it really is a video card issue. I’m using a GEForce 7300 something or other and whether or not it’s an ATI card I have no idea. But your workaround of using “shaded” instead of textured is working for me so…

Thanks again.

Hi,

I’ll get this when I forgot to UV map my objects…

Cheers!

Textured mode will display objects as white, if they do not have a texture. It doesn’t matter that they have a black (or any other colored) material … the objects will need UV mapped textures.