textured objects dont have shading

When I UV map an object, why doesn’t it have shading?

I think the same thing happened to me earlier. In UV Face Select, select a face, and where the bar at the bottomof the 3D view says View, Select, and Face, choose ‘Face’, then ‘Active Draw Mode’, then check “Light”. then select the other faces, and select Face>Copy Draw Mode. I hope that helps.

That’s not in the 2.46 version . . .

because blender you only uv mapped it? lol
You need to ao bake the lighting and add
the texture and all sort of sharers are out
there just have to ask everyone?but I ask
the same thing.

If your talking about the real time shading. You can fix it by going into edit mode, selecting a face, going into the texture face tab in the edit buttons and clicking on the light option. Then select all of the faces on the object and click ctrl-c and copy active mode.
Otherwise blender materials work quite nicely.