Textured plane within a transparent object

Hello,
I have an octahedron that is partially transparent, and a textured plane (a yellow question mark). I want to place the plane within the transparent octahedron, but when I place the plane in the object, the texture becomes black. If i place the plane so it’s behind the object, it will render normally and you can see the question mark through the object. Does anyone know what I might be doing wrong or missing? I’ve attached a file to show what I’m describing [ATTACH]click me[/ATTACH].
Thanks.

Attachments

itemboxes.blend (621 KB)

In the materials of the planes you need to enable ‘Receive Transparent’ under thr Material / Shadows panel so it can receive transparent shadows.

Also for the plane materials why have you enabled ‘Vertex paint Color’ in the material / Options panel ?
Disable it and change the colour of the plane something other than the current black material

Oh I see, thank you.
I’m fairly new so I’m still trying to learn what everything does, but I should have looked more closely at the materials window.

Also for the plane materials why have you enabled ‘Vertex paint Color’ in the material / Options panel ?
Disable it and change the colour of the plane something other than the current black material

You’re talking about the plane inside the object right? I’m not sure why you saw that enabled, as I don’t see it enabled in my file… odd.
I changed the colour of the plane though, and it fixed another problem I was having, regarding the texture of the plane turning black at times (briefly after it rotates faces).