textures and material not showing in texture view but showing in render view

Hi
I have a slight problem, i searched a bit and didn’t found answers so i came to ask here.
I am working on a videogame project, as such i am making the stage, somehow some walls don’t show in texture mode but they do in render mode (and they dont show on unity )
(the red on unity is the skybox and not the textures, if anyone had doubts)
I hope it’s just a simple error on my part .
Thanks for your time.






My first guess would be you have the wall and ceiling normals are pointed the wrong way.

Select the wall/ceiling objects, go into edit mode, and see if Flip Direction in the toolbar does anything. You may also choose to uncheck Backface Culling in the properties bar (N key).

If that’s a UV mapped image texture you need to change the Mapping from Generate to UV and select your UV map. It shows in textured mode because it’s showing you the result of whatever you’ve done in the UV editor, but the render doesn’t know to do that until you tell the texture to use that setup.

Thanks dear brony, it was indeed a normal problem, i duplicated the wall and fliped directions to have it 2 faced (i hope that’s the right thing to do)